<!doctype html>
<html>
<head>
<script src="/cdn-cgi/apps/head/XdxO9v-BYGp_5n0aQz6Vd1VwO_c.js"></script><script type='text/javascript'>var _sf_startpt=(new Date()).getTime()</script>
<meta http-equiv="Content-Type" content="text/html; charset=utf-8" />
<meta name="keywords" content="Trinidad and Tobago, News, Business, Sports, Trinidad Guardian Newspaper" />
<link rel="shortcut icon" href="http://www.guardian.co.tt/sites/default/files/guardianfav1.ico" type="image/vnd.microsoft.icon" />
<meta name="rating" content="general" />
<meta name="generator" content="Drupal 7 (http://drupal.org)" />
<link rel="image_src" href="http://www.guardian.co.tt/sites/default/files/front%2003_5.jpg" />
<link rel="canonical" href="http://www.guardian.co.tt/covers/thursday-3rd-may-2018" />
<meta property="fb:admins" content="559680181" />
<meta property="og:type" content="website" />
<meta property="og:site_name" content="The Trinidad Guardian Newspaper" />
<meta property="og:url" content="http://www.guardian.co.tt/covers/thursday-3rd-may-2018" />
<meta property="og:title" content="Thursday 3rd May, 2018" />
<meta property="og:updated_time" content="2018-05-03T01:20:32-04:00" />
<meta property="og:image" content="http://www.guardian.co.tt/sites/default/files/front%2003_5.jpg" />
<meta name="twitter:card" content="summary_large_image" />
<meta name="twitter:creator" content="@guardiantt" />
<meta name="twitter:creator:id" content="48003020" />
<meta name="twitter:title" content="Thursday 3rd May, 2018" />
<meta name="twitter:image" content="http://www.guardian.co.tt/sites/default/files/front%2003_5.jpg" />
<meta property="article:published_time" content="2018-05-03T01:20:32-04:00" />
<meta property="article:modified_time" content="2018-05-03T01:20:32-04:00" />
<meta itemprop="name" content="Thursday 3rd May, 2018" />
<title>Thursday 3rd May, 2018 | The Trinidad Guardian Newspaper</title>
<link type="text/css" rel="stylesheet" href="http://www.guardian.co.tt/sites/default/files/css/css_xE-rWrJf-fncB6ztZfd2huxqgxu4WO-qwma6Xer30m4.css" media="all" />
<link type="text/css" rel="stylesheet" href="http://www.guardian.co.tt/sites/default/files/css/css_dOhuNZJFrahWaLVt5TX99Cxv3rFN7c08CsNkW8Qj1ws.css" media="all" />
<link type="text/css" rel="stylesheet" href="http://www.guardian.co.tt/sites/default/files/css/css_E2gF4iZ54xcbTX-uB4pQz6L6XNrloqhRw_RoBKk4jtg.css" media="all" />
<link type="text/css" rel="stylesheet" href="http://www.guardian.co.tt/sites/default/files/css/css_5wfXOWVzB54BcGhlhAcevQ4dJIYgEPZEKFH3-thh1BI.css" media="all" />
<script type="text/javascript" src="//code.jquery.com/jquery-1.7.2.js"></script>
<script type="text/javascript">
<!--//--><![CDATA[//><!--
window.jQuery || document.write("<script src='/sites/all/modules/jquery_update/replace/jquery/1.7/jquery.js'>\x3C/script>")
//--><!]]>
</script>
<script type="text/javascript" src="http://www.guardian.co.tt/sites/default/files/js/js_LfUGIy9Vp2Dt2xynvxakyPKZeYWR-p0pz4e5xuX4-d8.js"></script>
<script type="text/javascript" src="http://www.guardian.co.tt/sites/default/files/js/js_9onouvIoBbig13lHXjy3jwR9b7Zs_iZ_Ve_2hJju0gs.js"></script>
<script type="text/javascript" src="http://www.guardian.co.tt/sites/default/files/js/js_DG0_i9to4jdZTwjB2N4pEwU3vzp3DnLHFJHHqayeUkM.js"></script>
<script type="text/javascript" src="http://www.guardian.co.tt/sites/all/modules/lightbox2/js/lightbox.js?1525382769"></script>
<script type="text/javascript" src="http://www.guardian.co.tt/sites/default/files/js/js_sK97EtSSEH8XYrlSSLHKTL_EeCB2rADmlEmczmELGEQ.js"></script>
<script type="text/javascript" src="http://www.guardian.co.tt/sites/default/files/js/js_PbzSuJhx0LotUBNgcU1CCaQ4VZCdzL1XIzZivTxwheI.js"></script>
<script type="text/javascript">
<!--//--><![CDATA[//><!--
jQuery.extend(Drupal.settings, {"basePath":"\/","pathPrefix":"","ajaxPageState":{"theme":"publishing","theme_token":"LtvTcdJZTR2enzo57A0GzywtJxY9Djx1TdiKVpCB5tc","jquery_version":"1.7","js":{"sites\/all\/modules\/block_refresh\/js\/block_refresh.js":1,"\/\/code.jquery.com\/jquery-1.7.2.js":1,"0":1,"misc\/jquery.once.js":1,"misc\/drupal.js":1,"sites\/all\/modules\/jquery_update\/replace\/ui\/external\/jquery.cookie.js":1,"sites\/all\/modules\/jquery_update\/replace\/misc\/jquery.form.js":1,"misc\/ajax.js":1,"sites\/all\/modules\/jquery_update\/js\/jquery_update.js":1,"sites\/all\/modules\/guardian_weather\/js\/weather.js":1,"sites\/all\/modules\/lightbox2\/js\/lightbox.js":1,"sites\/all\/modules\/views\/js\/base.js":1,"misc\/progress.js":1,"sites\/all\/modules\/views\/js\/ajax_view.js":1,"sites\/all\/themes\/publishing\/js\/sites.js":1},"css":{"modules\/system\/system.base.css":1,"modules\/system\/system.menus.css":1,"modules\/system\/system.messages.css":1,"modules\/system\/system.theme.css":1,"modules\/aggregator\/aggregator.css":1,"sites\/all\/modules\/date\/date_api\/date.css":1,"sites\/all\/modules\/date\/date_popup\/themes\/datepicker.1.7.css":1,"modules\/field\/theme\/field.css":1,"sites\/all\/modules\/guardian_weather\/css\/weather.css":1,"modules\/node\/node.css":1,"modules\/poll\/poll.css":1,"modules\/user\/user.css":1,"sites\/all\/modules\/youtube\/css\/youtube.css":1,"sites\/all\/modules\/views\/css\/views.css":1,"sites\/all\/modules\/ckeditor\/css\/ckeditor.css":1,"sites\/all\/modules\/block_refresh\/css\/block_refresh.css":1,"sites\/all\/modules\/ctools\/css\/ctools.css":1,"sites\/all\/modules\/lightbox2\/css\/lightbox.css":1,"sites\/all\/modules\/sharebar\/css\/sharebar.css":1,"sites\/all\/themes\/publishing\/css\/default.css":1,"sites\/all\/themes\/publishing\/css\/layout.css":1,"sites\/all\/themes\/publishing\/css\/style.css":1,"sites\/all\/themes\/publishing\/css\/normalize.css":1,"sites\/all\/themes\/publishing\/css\/responsive.css":1}},"block_refresh":{"settings":{"block-block-74":{"element":"block-block-74","auto":1,"manual":0,"init":0,"arguments":1,"panels":0,"timer":"30","block":{"block":"block","delta":"74"},"bypass_page_cache":0,"bypass_external_cache":""}},"args":["node","143827"],"query":""},"lightbox2":{"rtl":0,"file_path":"\/(\\w\\w\/)public:\/","default_image":"\/sites\/all\/modules\/lightbox2\/images\/brokenimage.jpg","border_size":10,"font_color":"000","box_color":"fff","top_position":"","overlay_opacity":"0.8","overlay_color":"000","disable_close_click":true,"resize_sequence":0,"resize_speed":400,"fade_in_speed":400,"slide_down_speed":600,"use_alt_layout":false,"disable_resize":false,"disable_zoom":false,"force_show_nav":false,"show_caption":true,"loop_items":false,"node_link_text":"View Image Details","node_link_target":false,"image_count":"Image !current of !total","video_count":"Video !current of !total","page_count":"Page !current of !total","lite_press_x_close":"press \u003Ca href=\u0022#\u0022 onclick=\u0022hideLightbox(); return FALSE;\u0022\u003E\u003Ckbd\u003Ex\u003C\/kbd\u003E\u003C\/a\u003E to close","download_link_text":"","enable_login":false,"enable_contact":false,"keys_close":"c x 27","keys_previous":"p 37","keys_next":"n 39","keys_zoom":"z","keys_play_pause":"32","display_image_size":"original","image_node_sizes":"()","trigger_lightbox_classes":"","trigger_lightbox_group_classes":"","trigger_slideshow_classes":"","trigger_lightframe_classes":"","trigger_lightframe_group_classes":"","custom_class_handler":0,"custom_trigger_classes":"","disable_for_gallery_lists":true,"disable_for_acidfree_gallery_lists":true,"enable_acidfree_videos":true,"slideshow_interval":5000,"slideshow_automatic_start":true,"slideshow_automatic_exit":true,"show_play_pause":true,"pause_on_next_click":false,"pause_on_previous_click":true,"loop_slides":false,"iframe_width":600,"iframe_height":400,"iframe_border":1,"enable_video":false},"views":{"ajax_path":"\/views\/ajax","ajaxViews":{"views_dom_id:f878370c6cf6358a98e3898962915302":{"view_name":"publication_most_read","view_display_id":"block","view_args":"","view_path":"node\/143827","view_base_path":null,"view_dom_id":"f878370c6cf6358a98e3898962915302","pager_element":0}}},"urlIsAjaxTrusted":{"\/views\/ajax":true}});
//--><!]]>
</script>
<script type="text/javascript">

  var _gaq = _gaq || [];
  _gaq.push(['_setAccount', 'UA-21130176-21']);
  _gaq.push(['_trackPageview']);

  (function() {
    var ga = document.createElement('script'); ga.type = 'text/javascript'; ga.async = true;
    ga.src = ('https:' == document.location.protocol ? 'https://ssl' : 'http://www') + '.google-analytics.com/ga.js';
    var s = document.getElementsByTagName('script')[0]; s.parentNode.insertBefore(ga, s);
  })();

</script>
<script type="text/javascript">

  var _gaq = _gaq || [];
  _gaq.push(['_setAccount', 'UA-21130176-19']);
  _gaq.push(['_setDomainName', 'guardian.co.tt']);
  _gaq.push(['_setAllowLinker', true]);
  _gaq.push(['_trackPageview']);

  (function() {
    var ga = document.createElement('script'); ga.type = 'text/javascript'; ga.async = true;
    ga.src = ('https:' == document.location.protocol ? 'https://ssl' : 'http://www') + '.google-analytics.com/ga.js';
    var s = document.getElementsByTagName('script')[0]; s.parentNode.insertBefore(ga, s);
  })();

</script>
<link rel="shortcut icon" type="image/ico" href="http://www.guardian.co.tt/images/gfavicon.ico" />
<meta http-equiv="X-UA-Compatible" content="IE=edge" />
<meta name="application-name" content="The Trinidad Guardian Newspaper" />
<meta name="msapplication-starturl" content="http://www.guardian.co.tt" />
<meta name="msapplication-navbutton-color" content="#EB1D25" />
<meta name="viewport" content="width=device-width, initial-scale=1.0, maximum-scale=5.0, user-scalable=yes">
<meta name="msapplication-tooltip" content="Start Trinidad Guardian Newspaper" />

</head>
<body class="html not-front not-logged-in two-sidebars page-node page-node- page-node-143827 node-type-cover   covers">
<div id="search">
<a href="#" class="close">close</a>
<h4> Search </h4>
<div id="search-block-form">
<script>
  (function() {
    var cx = 'partner-pub-4814196096164925:9533398938';
    var gcse = document.createElement('script');
    gcse.type = 'text/javascript';
    gcse.async = true;
    gcse.src = (document.location.protocol == 'https:' ? 'https:' : 'http:') +
        '//www.google.com/cse/cse.js?cx=' + cx;
    var s = document.getElementsByTagName('script')[0];
    s.parentNode.insertBefore(gcse, s);
  })();
</script>
<gcse:search></gcse:search>
</div>
</div>
<div id="page" class="page">

<div id="header">
<div id="logo">
<a href="/" title="Home" rel="home" id="logo">
<img src="http://www.guardian.co.tt/sites/all/themes/publishing/logo.png" alt="Home" />
</a>
</div>
<div id="updated">Last update: 03-May-2018 2:56 am<br />
Thursday, May 03, 2018<br />
</div>
<div id="social">
<div id="social-media">
<a href="http://guardian.co.tt/sitemap" id="rss" target="_blank"></a>
<a href="https://twitter.com/guardiantt" id="twitter" target="_blank"></a>
<a href="https://www.facebook.com/ttguardian" id="facebook" target="_blank"></a>
<a href="https://plus.google.com/u/0/b/114657292481933475304/" id="googleplus" target="_blank"></a>
<a href="/cdn-cgi/l/email-protection#80e9eef4e5f2eee5f4aee5e4e9f4eff2c0e7f5e1f2e4e9e1eeaee3efaef4f4" id="mail" target="_blank"></a>
<p id="site-title">Trinidad & Tobago Guardian Online</p>
</div>
</div>
<div id="header-region">
<div class="region region-header">
<div id="block-block-106" class="block block-block mobile-menu block-odd clearfix">
<div class="block-inner">
<div class="content">
<a href="#" id="menu-button">menu</a> </div>
</div>
</div> <div id="block-menu-menu-short-menu" class="block block-menu no-title block-even clearfix">
<div class="block-inner">
<h2 class="block-title">Short Menu</h2>
<div class="content">
<ul class="menu"><li class="first leaf"><a href="/news">News</a></li>
<li class="leaf"><a href="/sports">Sport</a></li>
<li class="leaf"><a href="/business">Business</a></li>
<li class="leaf mobile-link"><a href="http://www.guardian.co.tt/business-guardian">Business Guardian</a></li>
<li class="leaf"><a href="/lifestyle">Lifestyle</a></li>
<li class="leaf"><a href="/columnists">Columnists</a></li>
<li class="leaf mobile-link"><a href="http://www.guardian.co.tt/Letters">Letters</a></li>
<li class="leaf mobile-link"><a href="http://www.guardian.co.tt/entertainment">Entertainment</a></li>
<li class="leaf"><a href="/editorial">Editorial</a></li>
<li class="leaf mobile-link"><a href="/death-notices">Death Notices</a></li>
<li class="leaf mobile-link"><a href="http://classifieds.guardian.co.tt/RealEstate/Default.aspx" target="_blank">Classifieds</a></li>
<li class="leaf mobile-link"><a href="http://subscriptions.guardian.co.tt/edg/" target="_blank">Digital Guardian</a></li>
<li class="leaf mobile-link"><a href="http://www.guardian.co.tt/archive" target="_blank">Archives</a></li>
<li class="leaf mobile-link"><a href="http://classifieds.guardian.co.tt/RealEstate/Default.aspx" target="_blank">Real Estate</a></li>
<li class="leaf mobile-link"><a href="http://www.guardian.co.tt/digital/subscriptions" target="_blank">Subscriptions</a></li>
<li class="leaf mobile-link"><a href="http://www.guardian.co.tt/your-stories">Your Stories</a></li>
<li class="last leaf mobile-link"><a href="http://iamaguardiantt.tumblr.com/" target="_blank">I am Guardian</a></li>
</ul> </div>
</div>
</div>  </div>
</div>
<ol id="sec-menu">

<li><a id="search-button" href="#">Search</a></li>
</ol>
</div> 
<div id="hidden-menu">
<div class="region region-hidden-menu">
<div id="block-system-user-menu" class="block block-system no-title block-menu block-odd clearfix">
<div class="block-inner">
<h2 class="block-title">User menu</h2>
<div class="content">
<ul class="menu"><li class="first leaf"><a href="/business-guardian">Business Guardian</a></li>
<li class="leaf"><a href="/entertainment">Entertainment</a></li>
<li class="leaf"><a href="/Letters">Letters</a></li>
<li class="leaf"><a href="/death-notices">Death Notices</a></li>
<li class="leaf"><a href="http://www.guardian.co.tt/archive">Archives</a></li>
<li class="leaf"><a href="http://classifieds.guardian.co.tt/RealEstate/Default.aspx">Real Estate</a></li>
<li class="leaf"><a href="http://classifieds.guardian.co.tt/" target="_blank">Classifieds</a></li>
<li class="leaf no-mobile"><a href="http://www.guardian.co.tt/digital/subscriptions" target="_blank">Subscriptions</a></li>
<li class="leaf no-mobile"><a href="http://iamaguardiantt.tumblr.com/" target="_blank">I am Guardian</a></li>
<li class="last leaf"><a href="http://www.guardian.co.tt/sea">SEA Math</a></li>
</ul> </div>
</div>
</div>  </div>
</div>
<div id="banner">
<div class="region region-banner">
<div id="block-block-11" class="block block-block top-ad desktopad ads728 cell-lg-7 block-even clearfix">
<div class="block-inner">
<div class="content">
<center><iframe src="http://www.guardian.co.tt/adcode/leaderboard.html" frameborder="0" width="728" height="90" style="padding:0; margin:0;" scrolling="no"></iframe></center> </div>
</div>
</div> <div id="block-block-63" class="block block-block digital-ad desktopad  cell-lg-5 block-odd clearfix">
<div class="block-inner">
<div class="content">
<center><iframe src="http://www.guardian.co.tt/adcode/headersmall.html" frameborder="0" width="450" height="90" style="padding:0; margin:0;" scrolling="no"></iframe></center> </div>
</div>
</div> <div id="block-block-107" class="block block-block ads600 mobileads block-even clearfix">
<div class="block-inner">
<div class="content">
<script data-cfasync="false" src="/cdn-cgi/scripts/d07b1474/cloudflare-static/email-decode.min.js"></script><script type='text/javascript'>
  var googletag = googletag || {};
  googletag.cmd = googletag.cmd || [];
  (function() {
    var gads = document.createElement('script');
    gads.async = true;
    gads.type = 'text/javascript';
    var useSSL = 'https:' == document.location.protocol;
    gads.src = (useSSL ? 'https:' : 'http:') +
      '//www.googletagservices.com/tag/js/gpt.js';
    var node = document.getElementsByTagName('script')[0];
    node.parentNode.insertBefore(gads, node);
  })();
</script>
<script type='text/javascript'>
  googletag.cmd.push(function() {
    googletag.defineSlot('/103800131/mobile600', [600, 100], 'div-gpt-ad-1466003545412-0').addService(googletag.pubads());
    googletag.pubads().enableSingleRequest();
    googletag.pubads().collapseEmptyDivs();
    googletag.enableServices();
  });
</script>

<div id='div-gpt-ad-1466003545412-0' style='height:100px; width:600px; margin:0 auto;'>
<script type='text/javascript'>
googletag.cmd.push(function() { googletag.display('div-gpt-ad-1466003545412-0'); });
</script>
</div> </div>
</div>
</div> <div id="block-block-108" class="block block-block ads320 mobileads block-odd clearfix">
<div class="block-inner">
<div class="content">
<script type='text/javascript'>
  var googletag = googletag || {};
  googletag.cmd = googletag.cmd || [];
  (function() {
    var gads = document.createElement('script');
    gads.async = true;
    gads.type = 'text/javascript';
    var useSSL = 'https:' == document.location.protocol;
    gads.src = (useSSL ? 'https:' : 'http:') +
      '//www.googletagservices.com/tag/js/gpt.js';
    var node = document.getElementsByTagName('script')[0];
    node.parentNode.insertBefore(gads, node);
  })();
</script>
<script type='text/javascript'>
  googletag.cmd.push(function() {
    googletag.defineSlot('/103800131/mobile320', [320, 90], 'div-gpt-ad-1467390568976-0').addService(googletag.pubads());
    googletag.pubads().enableSingleRequest();
    googletag.pubads().collapseEmptyDivs();
    googletag.enableServices();
  });
</script>

<div id='div-gpt-ad-1467390568976-0' style='height:90px; width:320px; margin:0 auto;'>
<script type='text/javascript'>
googletag.cmd.push(function() { googletag.display('div-gpt-ad-1467390568976-0'); });
</script>
</div> </div>
</div>
</div>  </div>
</div>

<div id="main" class="clearfix">
<div id="content">
<div id="content-inner" class="inner column center">
<div id="content-header">
<h2 class="element-invisible">You are here</h2><div class="breadcrumb"><a href="/">Home</a></div>
<div class="strapandslug"></div>
<h1 class="title">Thursday 3rd May, 2018 </h1>
<div class="tabs"></div>
</div> 

<div id="content-area">
<div class="region region-content">
<div id="block-system-main" class="block block-system block-even clearfix">
<div class="block-inner">
<div class="content">
<div id="node-143827" class="node node-cover node-promoted node-odd">
<div class="node-inner">
<div class="desktopads ads600">
<center>
<script async src="//pagead2.googlesyndication.com/pagead/js/adsbygoogle.js"></script>

<ins class="adsbygoogle" style="display:inline-block;width:580px;height:90px" data-ad-client="ca-pub-4814196096164925" data-ad-slot="4646641906"></ins>
<script>
        (adsbygoogle = window.adsbygoogle || []).push({});
        </script>
</center>
</div>
<div class="content">
<div id=content-read>
<div class="field field-name-field-image field-type-image field-label-hidden"><div class="field-items"><div class="field-item even"><img typeof="foaf:Image" src="http://www.guardian.co.tt/sites/default/files/front%2003_5.jpg" width="600" height="760" alt="" /></div></div></div> </div>
</div>
<div class="desktopads ads600">
<center>
<script async src="//pagead2.googlesyndication.com/pagead/js/adsbygoogle.js"></script>

<ins class="adsbygoogle" style="display:inline-block;width:580px;height:90px" data-ad-client="ca-pub-4814196096164925" data-ad-slot="4646641906"></ins>
<script>
        (adsbygoogle = window.adsbygoogle || []).push({});
        </script>
</center>
</div>
<div class="links"></div>
</div> 
</div> 
</div>
</div>
</div>  </div>
</div>
</div>
</div> 


<div id="sidebar-first" class="column sidebar first">
<div id="sidebar-first-inner" class="inner">
<div class="region region-sidebar-first">
<div id="block-views-publication_most_read-block" class="block block-views internal-popular no-mobile block-odd clearfix">
<div class="block-inner">
<h2 class="block-title">In case you missed it.</h2>
<div class="content">
<div class="view view-publication-most-read view-id-publication_most_read view-display-id-block view-dom-id-f878370c6cf6358a98e3898962915302">
<div class="view-content">
<table class="views-view-grid cols-1">
<tbody>
<tr class="row-1 row-first">
<td class="col-1 col-first">
<div class="views-field views-field-title"> <span class="field-content"><a href="/sports/2018-05-02/windies-slump-historic-low-test-rankings">Windies slump to historic low in Test rankings</a></span> </div>
<div class="views-field views-field-field-image"> <div class="field-content"><img typeof="foaf:Image" src="http://www.guardian.co.tt/sites/default/files/styles/thumbnail/public/field/image/WI%20suck.jpg?itok=hTW4dLSZ" width="100" height="66" alt="" /></div> </div>
<div class="views-field views-field-body"> <div class="field-content"><p>LONDON—West Indies have slumped to ninth in the latest International Cricket Council Test rankings, a historic low for the Caribbean side in the game’s longest format.</p></div> </div> </td>
</tr>
<tr class="row-2">
<td class="col-1 col-first">
<div class="views-field views-field-title"> <span class="field-content"><a href="/entertainment/2018-05-02/mcdca-serves-tasty-jazz-treats-pos">MCDCA serves up tasty jazz treats in PoS</a></span> </div>
<div class="views-field views-field-field-image"> <div class="field-content"><img typeof="foaf:Image" src="http://www.guardian.co.tt/sites/default/files/styles/thumbnail/public/field/image/napa.jpg?itok=vVj3emwW" width="100" height="71" alt="" /></div> </div>
<div class="views-field views-field-body"> <div class="field-content"><p>For those who could not go to Tobago for the Jazz performances, the Ministry of Community Development, Culture and the Arts (MCDCA) gave them a day of Jazz with <a href="/cdn-cgi/l/email-protection#87cbeef1e2c7cbf2e9e4ef"><span class="__cf_email__" data-cfemail="ffb396899abfd1d1d1">[email&#160;protected]</span></div> </div> </td>
</tr>
<tr class="row-3">
<td class="col-1 col-first">
<div class="views-field views-field-title"> <span class="field-content"><a href="/sports/2018-05-02/ramsaran-calls-dinas-step-down">Ramsaran calls for Dinas to step down</a></span> </div>
<div class="views-field views-field-field-image"> <div class="field-content"><img typeof="foaf:Image" src="http://www.guardian.co.tt/sites/default/files/styles/thumbnail/public/field/image/Dinanath%20Ramnarine_3.jpg?itok=lTBnimrW" width="82" height="100" alt="" /></div> </div>
<div class="views-field views-field-body"> <div class="field-content"><p>Former Government minister Manohar Ramsaran has launched a broadside against chairman of the Sport Company of T&amp;T SPORTT Dinanath Ramnarine, calling on him to resign immediately.</p></div> </div> </td>
</tr>
<tr class="row-4">
<td class="col-1 col-first">
<div class="views-field views-field-title"> <span class="field-content"><a href="/news/2018-05-01/senators-against-retroactive-property-tax">Senators against retroactive Property Tax</a></span> </div>
<div class="views-field views-field-field-image"> <div class="field-content"><img typeof="foaf:Image" src="http://www.guardian.co.tt/sites/default/files/styles/thumbnail/public/field/image/Stephen%20Creese_0.jpg?itok=K_8z72xz" width="100" height="65" alt="" /></div> </div>
<div class="views-field views-field-body"> <div class="field-content"><p>Ridiculous to have retroactive Property Tax!</p></div> </div> </td>
</tr>
<tr class="row-5">
<td class="col-1 col-first">
<div class="views-field views-field-title"> <span class="field-content"><a href="/news/2018-05-01/three-hours-terror">Three hours of terror</a></span> </div>
<div class="views-field views-field-field-image"> <div class="field-content"><img typeof="foaf:Image" src="http://www.guardian.co.tt/sites/default/files/styles/thumbnail/public/field/image/invasion.jpg?itok=sKh_zEgl" width="100" height="63" alt="" /></div> </div>
<div class="views-field views-field-body"> <div class="field-content"><p>Hog-tied, gagged and bleeding heavily, a La Romaine pastor begged Jehovah God to spare his life after bandits stormed his home, chopping him and his son before stealing two vehicles, jewellery and...</div> </div> </td>
</tr>
<tr class="row-6">
<td class="col-1 col-first">
<div class="views-field views-field-title"> <span class="field-content"><a href="/news/2018-05-01/govt-rolls-out-50m-laptop-initiative-sept">Govt rolls out $50m laptop initiative in Sept</a></span> </div>
<div class="views-field views-field-field-image"> <div class="field-content"><img typeof="foaf:Image" src="http://www.guardian.co.tt/sites/default/files/styles/thumbnail/public/field/image/laptop_0.jpg?itok=KvYyfeAh" width="100" height="59" alt="" /></div> </div>
<div class="views-field views-field-body"> <div class="field-content"><p>When the Ministry of Education rolls out its $50 million secondary school laptop programme for the new school term in September, students will not be allowed to take the computers home.</p></div> </div> </td>
</tr>
<tr class="row-7">
<td class="col-1 col-first">
<div class="views-field views-field-title"> <span class="field-content"><a href="/lifestyle/2018-05-02/police-and-mentally-ill-are-they-or-aren%E2%80%99t-they-trained">Police and the mentally ill: Are they or aren’t they trained?</a></span> </div>
<div class="views-field views-field-field-image"> <div class="field-content"><img typeof="foaf:Image" src="http://www.guardian.co.tt/sites/default/files/styles/thumbnail/public/field/image/Caroline%20C%20Ravello_143.jpg?itok=r456tqn8" width="89" height="100" alt="" /></div> </div>
<div class="views-field views-field-body"> <div class="field-content"><p>Minister Dillon: Yes, they are</p></div> </div> </td>
</tr>
<tr class="row-8">
<td class="col-1 col-first">
<div class="views-field views-field-title"> <span class="field-content"><a href="/lifestyle/2018-05-02/student-writers-feature-theatre-workshop-series">Student writers feature in theatre workshop series</a></span> </div>
<div class="views-field views-field-field-image"> <div class="field-content"><img typeof="foaf:Image" src="http://www.guardian.co.tt/sites/default/files/styles/thumbnail/public/field/image/Tony%20Hall_1.jpg?itok=Yo2dUIgV" width="100" height="48" alt="" /></div> </div>
<div class="views-field views-field-body"> <div class="field-content"><p>This evening, Wednesday, May 2, the Playwrights Workshop Trinbago’s Monthly Readers Theatre Series 2018 will feature excerpts from the work of student playwrights enrolled in the Department of...</div> </div> </td>
</tr>
<tr class="row-9">
<td class="col-1 col-first">
<div class="views-field views-field-title"> <span class="field-content"><a href="/sports/2018-05-02/mc-collin%E2%80%99s-mavericks-back-winning-ways">Mc Collin’s Mavericks back to winning ways</a></span> </div>
<div class="views-field views-field-field-image"> <div class="field-content"><img typeof="foaf:Image" src="http://www.guardian.co.tt/sites/default/files/styles/thumbnail/public/field/image/Kalifa%20Mc%20Collin.jpg?itok=uPjuT-62" width="95" height="100" alt="" /></div> </div>
<div class="views-field views-field-body"> <div class="field-content"><p>T&amp;T senior national women’s team goal-shooter, Kalifa Mc Collin and her benecos Mavericks got back to winning ways in the England Vitality Netball Super League when they dumped Team Bath 57-41...</div> </div> </td>
</tr>
<tr class="row-10 row-last">
<td class="col-1 col-first">
<div class="views-field views-field-title"> <span class="field-content"><a href="/lifestyle/2018-05-02/food-galore-lions">Food galore at Lions</a></span> </div>
<div class="views-field views-field-field-image"> <div class="field-content"><img typeof="foaf:Image" src="http://www.guardian.co.tt/sites/default/files/styles/thumbnail/public/field/image/South%20Africa%20High%20Commissioner%20Thami%20XN%20Ngwevela.jpg?itok=bmpGItU1" width="100" height="73" alt="" /></div> </div>
<div class="views-field views-field-body"> <div class="field-content"><p>For yet another year, the Port-of-Spain Central Lions staged a successful all-inclusive gourmet event.</p></div> </div> </td>
</tr>
</tbody>
</table>
</div>
</div> </div>
</div>
</div>  </div>
</div>
</div>

<div id="sidebar-second" class="column sidebar second">
<div id="sidebar-second-inner" class="inner">
<div class="region region-sidebar-second">
<div id="block-block-97" class="block block-block advertisment ads block-even clearfix">
<div class="block-inner">
<div class="content">
<script data-cfasync="false" src="/cdn-cgi/scripts/d07b1474/cloudflare-static/email-decode.min.js"></script><script async='async' src='https://www.googletagservices.com/tag/js/gpt.js'></script>
<script>
  var googletag = googletag || {};
  googletag.cmd = googletag.cmd || [];
</script>
<script>
  googletag.cmd.push(function() {
    googletag.defineSlot('/103800131/Guardian300x250', [300, 250], 'div-gpt-ad-1506623274501-0').addService(googletag.pubads());
    googletag.pubads().enableSingleRequest();
    googletag.pubads().collapseEmptyDivs();
    googletag.enableServices();
  });
</script>

<div id='div-gpt-ad-1506623274501-0' style='height:250px; width:300px;'>
<script>
googletag.cmd.push(function() { googletag.display('div-gpt-ad-1506623274501-0'); });
</script>
</div> </div>
</div>
</div> <div id="block-block-98" class="block block-block advertisment ads block-odd clearfix">
<div class="block-inner">
<div class="content">
<center><iframe src="http://www.guardian.co.tt/adcode/sidebar2.html" width="300" height="250" style="padding:0; margin:0; border:none; overflow:hidden" scrolling="no"></iframe></center> </div>
</div>
</div> <div id="block-block-9" class="block block-block advertisment google block-even clearfix">
<div class="block-inner">
<div class="content">
<center>
<script async src="//pagead2.googlesyndication.com/pagead/js/adsbygoogle.js"></script>

<ins class="adsbygoogle" style="display:inline-block;width:300px;height:250px" data-ad-client="ca-pub-4814196096164925" data-ad-slot="3725503905"></ins>
<script>
(adsbygoogle = window.adsbygoogle || []).push({});
</script>
</center> </div>
</div>
</div>  </div>
</div>
</div>

</div> 

<div id="footer_bottom">
<div class="region region-footer-bottom">
<div id="block-block-62" class="block block-block gml-logo left block-odd clearfix">
<div class="block-inner">
<div class="content">
<p><a href="http://corp.guardian.co.tt" target="_blank"><img alt="" src="data:image/png;base64,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" style="margin:5px 10px" /></a></p>
		</div>

  </div>
</div> <!-- /block-inner /block --><div id="block-block-6" class="block block-block disclaimer right block-even clearfix">
  <div class="block-inner">

                		
		<div class="content" >
		  <p>GUARDIAN MEDIA is not responsible for the content of external sites. Copyright © 2014 GUARDIAN MEDIA LIMITED</p>
		</div>

  </div>
</div> <!-- /block-inner /block --><div id="block-menu-menu-footer-links" class="block block-menu footer_menu right block-odd clearfix">
  <div class="block-inner">

                <h2 class="block-title">Footer links</h2>
          		
		<div class="content" >
		  <ul class="menu"><li class="first leaf"><a href="http://www.guardian.co.tt/annual-reports" target="_blank">Annual Reports</a></li>
<li class="leaf"><a href="/contact">Contact Us</a></li>
<li class="leaf"><a href="http://www.guardian.co.tt/archive">Archives</a></li>
<li class="leaf"><a href="http://www.guardian.co.tt/advertisewithus">E-Advertise with us</a></li>
<li class="leaf"><a href="/terms-of-services">Terms of Service</a></li>
<li class="leaf"><a href="/privacy">Privacy</a></li>
<li class="leaf"><a href="http://www.guardian.co.tt/rss.xml">RSS</a></li>
<li class="last leaf"><a href="/sitemap">Sitemap</a></li>
</ul>		</div>

  </div>
</div> <!-- /block-inner /block -->  </div>
    </div> <!-- /footer -->
  
</div> <!-- /page -->
  <script type="text/javascript" src="http://www.guardian.co.tt/sites/default/files/js/js_Z7V5r3e07DLgphu5J22FpwStC8vz_wqG2sMMRFsufbI.js"></script>
</body>
</html>
