<!doctype html>
<html>
<head>
<script src="/cdn-cgi/apps/head/VHcMIJ6V-jBYQ23f60W-0Q86utc.js"></script><script type='text/javascript'>var _sf_startpt=(new Date()).getTime()</script>
<meta http-equiv="Content-Type" content="text/html; charset=utf-8" />
<link rel="shortcut icon" href="http://www.guardian.co.tt/sites/default/files/guardianfav1.ico" type="image/vnd.microsoft.icon" />
<meta name="keywords" content="Life Lead,Peter Ray Blood" />
<meta name="description" content="With a full moon approaching there was water everywhere but people drank sumptuously from the flood of entertainment taking place nationwide. On Saturday, Yorke Inc held yet another bumper happening at the Salybia Nature Resort &amp;amp; Spa, venue for its" />
<meta name="description" content="With a full moon approaching there was water everywhere but people drank sumptuously from the flood of entertainment taking place nationwide. On Saturday, Yorke Inc held yet another bumper happening at the Salybia Nature Resort &amp; Spa, venue for its annual Wild Meat Soca Parang Food Festival. Artistes like Road March champ MX Prime, Scrunter, Baron, Kenny J, and DJs Howie T, Sounds of Kabuki and Duane kept patrons dancing until way after the party’s scheduled midnight completion. Also taking its crowd way into Sunday morning was Pan in D Rosa 7, staged by the Pan in D Rosa Committee and Tunapuna/Piarco Regional Corporation at Lime Boulevard, Santa Rosa Heights, Arima. Desperadoes, First Citizens Supernovas, bpTT Renegades, Republic Bank Exodus, PCS Nitrogen Silver Stars, CAL Invaders and San City Steel Symphony were just some of the steelbands that graced the occasion. Down South, Nialah Blackman had a successful launching of her debut album (Sokah) while back in the north it was Parang &amp; Steel hosted by PCS Nitrogen Silver Stars in Newtown. What can be said of Nialah’s premiere release? Her sound reflects the evolution of the genre, but stays true to its fundamental ethos as the “Soul of Calypso.” In a pre-show interview she said, “It’s the unity of cultures, bringing people together. Soca is togetherness, peace, love and harmony among all the races.” Nialah wants soca to be the sound of the future of T&amp;T and, based on the audience’s response last weekend she will keep her promise, “This concert is going to be an annual event. It will be a platform for young people to showcase their culture. Sometimes we can get lost in the influences of other genres and cultures, but we need to respect ours.” The granddaughter of late soca pioneer Ras Shorty I and daughter of 1979 National Calypso Queen Abbi Blackman, this drop-dead-gorgeous and talented soca princess is well poised and on her way to ascending to the pinnacle of the genre. Last Sunday was just a wee bit more sedate although patrons were seen dancing up a storm at the Paragon Sports &amp; Cultural Club’s annual Parang &amp; Soca Luncheon in Cocorite. Headlining this gig were Marcia Miranda, Los Vikingos de San Jose and DJ Cardo. Rounding off a weekend of non-stop entertainment action was the annual parang festival in Lopinot. This weekend is no different and fingers are crossed that the weather is kinder, especially for the many outdoor events. This evening Newtown Playboyz holds It’s A Sweet Parang Soca Lime at its Pan Theatre on Tragarete Road, from 6 pm. Live performances will come from Pelham Goddard &amp; Roots, Los Angeles de San Miguel, Marilyn Williams, Moricia Cagan, Nigel O’Connor and host Newtown Playboyz. Prayers are being offered for clear skies tomorrow evening as well when Republic Bank stages A Gift of Love, featuring The Love Movement, Adam Smith Square, Woodbrook, at 6 pm. Southern action includes the High Commission of India and the Mahatma Gandhi Institute for Cultural Co-operation, in collaboration with Ministry of Community Development, Culture and the Arts, staging Rhythms of Manipur from 6.30 pm. This will be held in Fyzabad at the Shri Siddhi Vinayaaka Avocat Mandir, on 296 Siparia Old Road, Avocat Village. I Dream A World, featuring bpTT Marionettes, is on • Continues on Page B10 • From Page B9  at Queen’s Hall, and The True Meaning of Christmas, featuring T&amp;T Youth Philharmonic (TTYP), Voices of The University School (VOUS) children’s choir and Euangelion Singers and Band will be staged at the National Academy for the Performing Arts (Napa), Port-of-Spain. These two concerts begin at 7.30 pm. The second instalment of Parang &amp; Steel 2017 will also be held tomorrow at Silver Stars and, in St James, on Mooneram Street, Cheers Pub will holds its lively Parang, Pork &amp; Pan, featuring The Love Bunch parang group, Sapophonics Steel, The Stella Band and more. Rock band jointpop is also in concert tomorrow at All Out Lounge, Queen’s Park Oval, Tragarete Road, Woodbrook with its Noise n Toys benefit. For the past 13 years, jointpop hosts and performs at this toy collection concert. The show also doubles as the jointpop Christmas office party and it is always well attended and a fun filled night. This will be the last jointpop gig of 2017 as the band is heading to the recording studio next Wednesday, until December 22 to record it’s eighth album, to be released in 2018. Recording will be done at STUDIO 303, the UTT studio at Napa. Top Seattle-based producer Paul Kimble will be on board again , to follow up the production he did on the last jointpop album Quicksand (2015). Kimble is the bassist and producer of legendary US band Grant Lee Buffalo. MusicTT has assisted jointpop with funding for the album recording. Also performing tomorrow night will be The Malcontents. The Noise and Toys concert costs $80 entry at the door, plus a gift wrapped toy with a label or note with the information of gender and the age group of the child. All the toys are collected on the night and then distributed to various unprivileged kids homes across the country. Remember the one and most important rule of entry: No Toy Guns please. Things cool down on Sunday evening with T&amp;T Youth Philharmonic (TTYP), Voices of The University School (VOUS) children’s choir and Euangelion Singers and Band at Napa, Port-of-Spain; and, The Marionettes’ I Dream A World finale at Queen’s Hall, St Ann’s. Christmas with the Saints 2  The students of St Mary’s College are embarking for a second year on their Christmas production Christmas with the Saints 2, to be at the college’s Centenary Hall on Pembroke Street, Port-of-Spain. This event is organised by Form Six students and will serve as a glorious night of entertainment for the parents, teachers and students of St Mary’s College, and to the wider public who wish to enjoy a Saturday night of music and performance. The concert brings out the best of the school’s present talent, including award-winning calypsonians Desle Julien, Duane O’Connor, Renaldo Alleyne-Noreiga and Reshawn Goodridge. The event also incorporates the talents of past students like vocalist Jake Salloum and instrumentalist Luke Walker. Besides solo performers like these, patrons can expect to be wowed by the school’s parang side Los Santos whose recent victories include placing third in the National Junior Parang Competition. The concert will similarly place emphasis on our national instrument, showcasing the college’s incomparable pan-side The Symphony of Saints, among pan soloists like Dylan Yuk Low. At the admission fee of a mere blue note ($100) this show is a steal-of-a-deal if ever there was one, especially with its star-studded retinue of guest performers. Guest artistes include Parang Queen Alicia Jaggassar and Los Alumnos de San Juan, 3Canal, The Flick, Ms Dija, Shortpants, Mastertone Salloum and La Nueva Experiencia. Jake Salloum is the creative director of Christmas with the Saints 2 and its musical director is Alea Jaggernauth. The show is produced entirely by the Form 6 Students of St. Mary’s College. Christmas Delicacies (fruit cake, pastelles etc) and drinks (sorrel, ponche de crème etc.) will be on sale and tickets are are available at the college’s office, or through Manager Enrico Rajah (623-8835/745-4391). Showtime is 7.30 pm. All proceeds go towards recurrent expenditure and the Music Room." />
<meta name="rating" content="general" />
<meta name="generator" content="Drupal 7 (http://drupal.org)" />
<link rel="image_src" href="http://www.guardian.co.tt/sites/default/files/field/image/parang%20pulse.jpg" />
<link rel="canonical" href="http://www.guardian.co.tt/life-lead/2017-12-08/sokah-parang-and-steel-heats-wet-weekend" />
<meta property="fb:admins" content="559680181" />
<meta property="og:type" content="website" />
<meta property="og:site_name" content="The Trinidad Guardian Newspaper" />
<meta property="og:url" content="http://www.guardian.co.tt/life-lead/2017-12-08/sokah-parang-and-steel-heats-wet-weekend" />
<meta property="og:title" content="Sokah, parang and steel heats up wet weekend" />
<meta property="og:description" content="With a full moon approaching there was water everywhere but people drank sumptuously from the flood of entertainment taking place nationwide. On Saturday, Yorke Inc held yet another bumper happening at the Salybia Nature Resort &amp; Spa, venue for its annual Wild Meat Soca Parang Food Festival. Artistes like Road March champ MX Prime, Scrunter, Baron, Kenny J, and DJs Howie T, Sounds of Kabuki and Duane kept patrons dancing until way after the party’s scheduled midnight completion. Also taking its crowd way into Sunday morning was Pan in D Rosa 7, staged by the Pan in D Rosa Committee and Tunapuna/Piarco Regional Corporation at Lime Boulevard, Santa Rosa Heights, Arima. Desperadoes, First Citizens Supernovas, bpTT Renegades, Republic Bank Exodus, PCS Nitrogen Silver Stars, CAL Invaders and San City Steel Symphony were just some of the steelbands that graced the occasion. Down South, Nialah Blackman had a successful launching of her debut album (Sokah) while back in the north it was Parang &amp; Steel hosted by PCS Nitrogen Silver Stars in Newtown. What can be said of Nialah’s premiere release? Her sound reflects the evolution of the genre, but stays true to its fundamental ethos as the “Soul of Calypso.” In a pre-show interview she said, “It’s the unity of cultures, bringing people together. Soca is togetherness, peace, love and harmony among all the races.” Nialah wants soca to be the sound of the future of T&amp;T and, based on the audience’s response last weekend she will keep her promise, “This concert is going to be an annual event. It will be a platform for young people to showcase their culture. Sometimes we can get lost in the influences of other genres and cultures, but we need to respect ours.” The granddaughter of late soca pioneer Ras Shorty I and daughter of 1979 National Calypso Queen Abbi Blackman, this drop-dead-gorgeous and talented soca princess is well poised and on her way to ascending to the pinnacle of the genre. Last Sunday was just a wee bit more sedate although patrons were seen dancing up a storm at the Paragon Sports &amp; Cultural Club’s annual Parang &amp; Soca Luncheon in Cocorite. Headlining this gig were Marcia Miranda, Los Vikingos de San Jose and DJ Cardo. Rounding off a weekend of non-stop entertainment action was the annual parang festival in Lopinot. This weekend is no different and fingers are crossed that the weather is kinder, especially for the many outdoor events. This evening Newtown Playboyz holds It’s A Sweet Parang Soca Lime at its Pan Theatre on Tragarete Road, from 6 pm. Live performances will come from Pelham Goddard &amp; Roots, Los Angeles de San Miguel, Marilyn Williams, Moricia Cagan, Nigel O’Connor and host Newtown Playboyz. Prayers are being offered for clear skies tomorrow evening as well when Republic Bank stages A Gift of Love, featuring The Love Movement, Adam Smith Square, Woodbrook, at 6 pm. Southern action includes the High Commission of India and the Mahatma Gandhi Institute for Cultural Co-operation, in collaboration with Ministry of Community Development, Culture and the Arts, staging Rhythms of Manipur from 6.30 pm. This will be held in Fyzabad at the Shri Siddhi Vinayaaka Avocat Mandir, on 296 Siparia Old Road, Avocat Village. I Dream A World, featuring bpTT Marionettes, is on • Continues on Page B10 • From Page B9  at Queen’s Hall, and The True Meaning of Christmas, featuring T&amp;T Youth Philharmonic (TTYP), Voices of The University School (VOUS) children’s choir and Euangelion Singers and Band will be staged at the National Academy for the Performing Arts (Napa), Port-of-Spain. These two concerts begin at 7.30 pm. The second instalment of Parang &amp; Steel 2017 will also be held tomorrow at Silver Stars and, in St James, on Mooneram Street, Cheers Pub will holds its lively Parang, Pork &amp; Pan, featuring The Love Bunch parang group, Sapophonics Steel, The Stella Band and more. Rock band jointpop is also in concert tomorrow at All Out Lounge, Queen’s Park Oval, Tragarete Road, Woodbrook with its Noise n Toys benefit. For the past 13 years, jointpop hosts and performs at this toy collection concert. The show also doubles as the jointpop Christmas office party and it is always well attended and a fun filled night. This will be the last jointpop gig of 2017 as the band is heading to the recording studio next Wednesday, until December 22 to record it’s eighth album, to be released in 2018. Recording will be done at STUDIO 303, the UTT studio at Napa. Top Seattle-based producer Paul Kimble will be on board again , to follow up the production he did on the last jointpop album Quicksand (2015). Kimble is the bassist and producer of legendary US band Grant Lee Buffalo. MusicTT has assisted jointpop with funding for the album recording. Also performing tomorrow night will be The Malcontents. The Noise and Toys concert costs $80 entry at the door, plus a gift wrapped toy with a label or note with the information of gender and the age group of the child. All the toys are collected on the night and then distributed to various unprivileged kids homes across the country. Remember the one and most important rule of entry: No Toy Guns please. Things cool down on Sunday evening with T&amp;T Youth Philharmonic (TTYP), Voices of The University School (VOUS) children’s choir and Euangelion Singers and Band at Napa, Port-of-Spain; and, The Marionettes’ I Dream A World finale at Queen’s Hall, St Ann’s. Christmas with the Saints 2  The students of St Mary’s College are embarking for a second year on their Christmas production Christmas with the Saints 2, to be at the college’s Centenary Hall on Pembroke Street, Port-of-Spain. This event is organised by Form Six students and will serve as a glorious night of entertainment for the parents, teachers and students of St Mary’s College, and to the wider public who wish to enjoy a Saturday night of music and performance. The concert brings out the best of the school’s present talent, including award-winning calypsonians Desle Julien, Duane O’Connor, Renaldo Alleyne-Noreiga and Reshawn Goodridge. The event also incorporates the talents of past students like vocalist Jake Salloum and instrumentalist Luke Walker. Besides solo performers like these, patrons can expect to be wowed by the school’s parang side Los Santos whose recent victories include placing third in the National Junior Parang Competition. The concert will similarly place emphasis on our national instrument, showcasing the college’s incomparable pan-side The Symphony of Saints, among pan soloists like Dylan Yuk Low. At the admission fee of a mere blue note ($100) this show is a steal-of-a-deal if ever there was one, especially with its star-studded retinue of guest performers. Guest artistes include Parang Queen Alicia Jaggassar and Los Alumnos de San Juan, 3Canal, The Flick, Ms Dija, Shortpants, Mastertone Salloum and La Nueva Experiencia. Jake Salloum is the creative director of Christmas with the Saints 2 and its musical director is Alea Jaggernauth. The show is produced entirely by the Form 6 Students of St. Mary’s College. Christmas Delicacies (fruit cake, pastelles etc) and drinks (sorrel, ponche de crème etc.) will be on sale and tickets are are available at the college’s office, or through Manager Enrico Rajah (623-8835/745-4391). Showtime is 7.30 pm. All proceeds go towards recurrent expenditure and the Music Room." />
<meta property="og:updated_time" content="2017-12-08T00:47:59-04:00" />
<meta property="og:image" content="http://www.guardian.co.tt/sites/default/files/field/image/parang%20pulse.jpg" />
<meta name="twitter:card" content="summary_large_image" />
<meta name="twitter:creator" content="@guardiantt" />
<meta name="twitter:creator:id" content="48003020" />
<meta name="twitter:title" content="Sokah, parang and steel heats up wet weekend" />
<meta name="twitter:description" content="With a full moon approaching there was water everywhere but people drank sumptuously from the flood of entertainment taking place nationwide. On Saturday, Yorke Inc held yet another bumper happening at the Salybia Nature Resort &amp; Spa, venue for its annual Wild Meat Soca Parang Food Festival. Artistes like Road March champ MX Prime, Scrunter, Baron, Kenny J, and DJs Howie T, Sounds of Kabuki and Duane kept patrons dancing until way after the party’s scheduled midnight completion. Also taking its crowd way into Sunday morning was Pan in D Rosa 7, staged by the Pan in D Rosa Committee and Tunapuna/Piarco Regional Corporation at Lime Boulevard, Santa Rosa Heights, Arima. Desperadoes, First Citizens Supernovas, bpTT Renegades, Republic Bank Exodus, PCS Nitrogen Silver Stars, CAL Invaders and San City Steel Symphony were just some of the steelbands that graced the occasion. Down South, Nialah Blackman had a successful launching of her debut album (Sokah) while back in the north it was Parang &amp; Steel hosted by PCS Nitrogen Silver Stars in Newtown. What can be said of Nialah’s premiere release? Her sound reflects the evolution of the genre, but stays true to its fundamental ethos as the “Soul of Calypso.” In a pre-show interview she said, “It’s the unity of cultures, bringing people together. Soca is togetherness, peace, love and harmony among all the races.” Nialah wants soca to be the sound of the future of T&amp;T and, based on the audience’s response last weekend she will keep her promise, “This concert is going to be an annual event. It will be a platform for young people to showcase their culture. Sometimes we can get lost in the influences of other genres and cultures, but we need to respect ours.” The granddaughter of late soca pioneer Ras Shorty I and daughter of 1979 National Calypso Queen Abbi Blackman, this drop-dead-gorgeous and talented soca princess is well poised and on her way to ascending to the pinnacle of the genre. Last Sunday was just a wee bit more sedate although patrons were seen dancing up a storm at the Paragon Sports &amp; Cultural Club’s annual Parang &amp; Soca Luncheon in Cocorite. Headlining this gig were Marcia Miranda, Los Vikingos de San Jose and DJ Cardo. Rounding off a weekend of non-stop entertainment action was the annual parang festival in Lopinot. This weekend is no different and fingers are crossed that the weather is kinder, especially for the many outdoor events. This evening Newtown Playboyz holds It’s A Sweet Parang Soca Lime at its Pan Theatre on Tragarete Road, from 6 pm. Live performances will come from Pelham Goddard &amp; Roots, Los Angeles de San Miguel, Marilyn Williams, Moricia Cagan, Nigel O’Connor and host Newtown Playboyz. Prayers are being offered for clear skies tomorrow evening as well when Republic Bank stages A Gift of Love, featuring The Love Movement, Adam Smith Square, Woodbrook, at 6 pm. Southern action includes the High Commission of India and the Mahatma Gandhi Institute for Cultural Co-operation, in collaboration with Ministry of Community Development, Culture and the Arts, staging Rhythms of Manipur from 6.30 pm. This will be held in Fyzabad at the Shri Siddhi Vinayaaka Avocat Mandir, on 296 Siparia Old Road, Avocat Village. I Dream A World, featuring bpTT Marionettes, is on • Continues on Page B10 • From Page B9  at Queen’s Hall, and The True Meaning of Christmas, featuring T&amp;T Youth Philharmonic (TTYP), Voices of The University School (VOUS) children’s choir and Euangelion Singers and Band will be staged at the National Academy for the Performing Arts (Napa), Port-of-Spain. These two concerts begin at 7.30 pm. The second instalment of Parang &amp; Steel 2017 will also be held tomorrow at Silver Stars and, in St James, on Mooneram Street, Cheers Pub will holds its lively Parang, Pork &amp; Pan, featuring The Love Bunch parang group, Sapophonics Steel, The Stella Band and more. Rock band jointpop is also in concert tomorrow at All Out Lounge, Queen’s Park Oval, Tragarete Road, Woodbrook with its Noise n Toys benefit. For the past 13 years, jointpop hosts and performs at this toy collection concert. The show also doubles as the jointpop Christmas office party and it is always well attended and a fun filled night. This will be the last jointpop gig of 2017 as the band is heading to the recording studio next Wednesday, until December 22 to record it’s eighth album, to be released in 2018. Recording will be done at STUDIO 303, the UTT studio at Napa. Top Seattle-based producer Paul Kimble will be on board again , to follow up the production he did on the last jointpop album Quicksand (2015). Kimble is the bassist and producer of legendary US band Grant Lee Buffalo. MusicTT has assisted jointpop with funding for the album recording. Also performing tomorrow night will be The Malcontents. The Noise and Toys concert costs $80 entry at the door, plus a gift wrapped toy with a label or note with the information of gender and the age group of the child. All the toys are collected on the night and then distributed to various unprivileged kids homes across the country. Remember the one and most important rule of entry: No Toy Guns please. Things cool down on Sunday evening with T&amp;T Youth Philharmonic (TTYP), Voices of The University School (VOUS) children’s choir and Euangelion Singers and Band at Napa, Port-of-Spain; and, The Marionettes’ I Dream A World finale at Queen’s Hall, St Ann’s. Christmas with the Saints 2  The students of St Mary’s College are embarking for a second year on their Christmas production Christmas with the Saints 2, to be at the college’s Centenary Hall on Pembroke Street, Port-of-Spain. This event is organised by Form Six students and will serve as a glorious night of entertainment for the parents, teachers and students of St Mary’s College, and to the wider public who wish to enjoy a Saturday night of music and performance. The concert brings out the best of the school’s present talent, including award-winning calypsonians Desle Julien, Duane O’Connor, Renaldo Alleyne-Noreiga and Reshawn Goodridge. The event also incorporates the talents of past students like vocalist Jake Salloum and instrumentalist Luke Walker. Besides solo performers like these, patrons can expect to be wowed by the school’s parang side Los Santos whose recent victories include placing third in the National Junior Parang Competition. The concert will similarly place emphasis on our national instrument, showcasing the college’s incomparable pan-side The Symphony of Saints, among pan soloists like Dylan Yuk Low. At the admission fee of a mere blue note ($100) this show is a steal-of-a-deal if ever there was one, especially with its star-studded retinue of guest performers. Guest artistes include Parang Queen Alicia Jaggassar and Los Alumnos de San Juan, 3Canal, The Flick, Ms Dija, Shortpants, Mastertone Salloum and La Nueva Experiencia. Jake Salloum is the creative director of Christmas with the Saints 2 and its musical director is Alea Jaggernauth. The show is produced entirely by the Form 6 Students of St. Mary’s College. Christmas Delicacies (fruit cake, pastelles etc) and drinks (sorrel, ponche de crème etc.) will be on sale and tickets are are available at the college’s office, or through Manager Enrico Rajah (623-8835/745-4391). Showtime is 7.30 pm. All proceeds go towards recurrent expenditure and the Music Room." />
<meta name="twitter:image" content="http://www.guardian.co.tt/sites/default/files/field/image/parang%20pulse.jpg" />
<meta property="article:published_time" content="2017-12-08T00:47:59-04:00" />
<meta property="article:modified_time" content="2017-12-08T00:47:59-04:00" />
<meta itemprop="name" content="Sokah, parang and steel heats up wet weekend" />
<meta itemprop="description" content="With a full moon approaching there was water everywhere but people drank sumptuously from the flood of entertainment taking place nationwide. On Saturday, Yorke Inc held yet another bumper happening at the Salybia Nature Resort &amp; Spa, venue for its annual Wild Meat Soca Parang Food Festival." />
<title>Sokah, parang and steel heats up wet weekend | The Trinidad Guardian Newspaper</title>
<style type="text/css" media="all">
@import url("http://www.guardian.co.tt/modules/system/system.base.css?p0e5yl");
@import url("http://www.guardian.co.tt/modules/system/system.menus.css?p0e5yl");
@import url("http://www.guardian.co.tt/modules/system/system.messages.css?p0e5yl");
@import url("http://www.guardian.co.tt/modules/system/system.theme.css?p0e5yl");
</style>
<style type="text/css" media="all">
@import url("http://www.guardian.co.tt/modules/aggregator/aggregator.css?p0e5yl");
@import url("http://www.guardian.co.tt/sites/all/modules/date/date_api/date.css?p0e5yl");
@import url("http://www.guardian.co.tt/sites/all/modules/date/date_popup/themes/datepicker.1.7.css?p0e5yl");
@import url("http://www.guardian.co.tt/modules/field/theme/field.css?p0e5yl");
@import url("http://www.guardian.co.tt/sites/all/modules/guardian_weather/css/weather.css?p0e5yl");
@import url("http://www.guardian.co.tt/modules/node/node.css?p0e5yl");
@import url("http://www.guardian.co.tt/modules/poll/poll.css?p0e5yl");
@import url("http://www.guardian.co.tt/modules/user/user.css?p0e5yl");
@import url("http://www.guardian.co.tt/sites/all/modules/youtube/css/youtube.css?p0e5yl");
@import url("http://www.guardian.co.tt/sites/all/modules/views/css/views.css?p0e5yl");
@import url("http://www.guardian.co.tt/sites/all/modules/ckeditor/css/ckeditor.css?p0e5yl");
</style>
<style type="text/css" media="all">
@import url("http://www.guardian.co.tt/sites/all/modules/block_refresh/css/block_refresh.css?p0e5yl");
@import url("http://www.guardian.co.tt/sites/all/modules/ctools/css/ctools.css?p0e5yl");
@import url("http://www.guardian.co.tt/sites/all/modules/lightbox2/css/lightbox.css?p0e5yl");
@import url("http://www.guardian.co.tt/sites/all/modules/sharebar/css/sharebar.css?p0e5yl");
</style>
<style type="text/css" media="all">
@import url("http://www.guardian.co.tt/sites/all/themes/publishing/css/default.css?p0e5yl");
@import url("http://www.guardian.co.tt/sites/all/themes/publishing/css/layout.css?p0e5yl");
@import url("http://www.guardian.co.tt/sites/all/themes/publishing/css/style.css?p0e5yl");
@import url("http://www.guardian.co.tt/sites/all/themes/publishing/css/normalize.css?p0e5yl");
@import url("http://www.guardian.co.tt/sites/all/themes/publishing/css/responsive.css?p0e5yl");
</style>
<script type="text/javascript" src="//code.jquery.com/jquery-1.7.2.js"></script>
<script type="text/javascript">
<!--//--><![CDATA[//><!--
window.jQuery || document.write("<script src='/sites/all/modules/jquery_update/replace/jquery/1.7/jquery.js'>\x3C/script>")
//--><!]]>
</script>
<script type="text/javascript" src="http://www.guardian.co.tt/misc/jquery.once.js?v=1.2"></script>
<script type="text/javascript" src="http://www.guardian.co.tt/misc/drupal.js?p0e5yl"></script>
<script type="text/javascript" src="http://www.guardian.co.tt/sites/all/modules/jquery_update/replace/ui/external/jquery.cookie.js?v=67fb34f6a866c40d0570"></script>
<script type="text/javascript" src="http://www.guardian.co.tt/sites/all/modules/jquery_update/replace/misc/jquery.form.js?v=2.69"></script>
<script type="text/javascript" src="http://www.guardian.co.tt/misc/ajax.js?v=7.56"></script>
<script type="text/javascript" src="http://www.guardian.co.tt/sites/all/modules/jquery_update/js/jquery_update.js?v=0.0.1"></script>
<script type="text/javascript" src="http://www.guardian.co.tt/sites/all/modules/guardian_weather/js/weather.js?p0e5yl"></script>
<script type="text/javascript" src="http://www.guardian.co.tt/sites/all/modules/lightbox2/js/lightbox.js?1512731682"></script>
<script type="text/javascript" src="http://www.guardian.co.tt/sites/all/modules/views/js/base.js?p0e5yl"></script>
<script type="text/javascript" src="http://www.guardian.co.tt/misc/progress.js?v=7.56"></script>
<script type="text/javascript" src="http://www.guardian.co.tt/sites/all/modules/views/js/ajax_view.js?p0e5yl"></script>
<script type="text/javascript" src="http://www.guardian.co.tt/sites/all/modules/field_group/field_group.js?p0e5yl"></script>
<script type="text/javascript" src="http://www.guardian.co.tt/sites/all/modules/spotim-comments/js/spot_im.js?p0e5yl"></script>
<script type="text/javascript" src="http://www.guardian.co.tt/sites/all/themes/publishing/js/sites.js?p0e5yl"></script>
<script type="text/javascript">
<!--//--><![CDATA[//><!--
!function(t,e,n){function a(t){var a=e.createElement("script");a.type="text/javascript",a.async=!0,a.src=("https:"===e.location.protocol?"https":"http")+":"+n,(t||e.body||e.head).appendChild(a)}function o(){var t=e.getElementsByTagName("script"),n=t[t.length-1];return n.parentNode} var p=o();t.spotId="sp_XC61vFgU",t.parentElement=p,a(p)}(window.SPOTIM={},document,"//www.spot.im/launcher/bundle.js");
//--><!]]>
</script>
<script type="text/javascript">
<!--//--><![CDATA[//><!--
jQuery.extend(Drupal.settings, {"basePath":"\/","pathPrefix":"","ajaxPageState":{"theme":"publishing","theme_token":"__wHhblZ_ZnwSEuzn8zbZKssfeJfQ6r0MreS-DQ6xr0","jquery_version":"1.7","js":{"sites\/all\/modules\/block_refresh\/js\/block_refresh.js":1,"\/\/code.jquery.com\/jquery-1.7.2.js":1,"0":1,"misc\/jquery.once.js":1,"misc\/drupal.js":1,"sites\/all\/modules\/jquery_update\/replace\/ui\/external\/jquery.cookie.js":1,"sites\/all\/modules\/jquery_update\/replace\/misc\/jquery.form.js":1,"misc\/ajax.js":1,"sites\/all\/modules\/jquery_update\/js\/jquery_update.js":1,"sites\/all\/modules\/guardian_weather\/js\/weather.js":1,"sites\/all\/modules\/lightbox2\/js\/lightbox.js":1,"sites\/all\/modules\/views\/js\/base.js":1,"misc\/progress.js":1,"sites\/all\/modules\/views\/js\/ajax_view.js":1,"sites\/all\/modules\/field_group\/field_group.js":1,"sites\/all\/modules\/spotim-comments\/js\/spot_im.js":1,"sites\/all\/themes\/publishing\/js\/sites.js":1,"1":1},"css":{"modules\/system\/system.base.css":1,"modules\/system\/system.menus.css":1,"modules\/system\/system.messages.css":1,"modules\/system\/system.theme.css":1,"modules\/aggregator\/aggregator.css":1,"sites\/all\/modules\/date\/date_api\/date.css":1,"sites\/all\/modules\/date\/date_popup\/themes\/datepicker.1.7.css":1,"modules\/field\/theme\/field.css":1,"sites\/all\/modules\/guardian_weather\/css\/weather.css":1,"modules\/node\/node.css":1,"modules\/poll\/poll.css":1,"modules\/user\/user.css":1,"sites\/all\/modules\/youtube\/css\/youtube.css":1,"sites\/all\/modules\/views\/css\/views.css":1,"sites\/all\/modules\/ckeditor\/css\/ckeditor.css":1,"sites\/all\/modules\/block_refresh\/css\/block_refresh.css":1,"sites\/all\/modules\/ctools\/css\/ctools.css":1,"sites\/all\/modules\/lightbox2\/css\/lightbox.css":1,"sites\/all\/modules\/sharebar\/css\/sharebar.css":1,"sites\/all\/themes\/publishing\/css\/default.css":1,"sites\/all\/themes\/publishing\/css\/layout.css":1,"sites\/all\/themes\/publishing\/css\/style.css":1,"sites\/all\/themes\/publishing\/css\/normalize.css":1,"sites\/all\/themes\/publishing\/css\/responsive.css":1}},"block_refresh":{"settings":{"block-block-74":{"element":"block-block-74","auto":1,"manual":0,"init":0,"arguments":1,"panels":0,"timer":"30","block":{"block":"block","delta":"74"},"bypass_page_cache":0,"bypass_external_cache":""}},"args":["node","138453"],"query":""},"lightbox2":{"rtl":0,"file_path":"\/(\\w\\w\/)public:\/","default_image":"\/sites\/all\/modules\/lightbox2\/images\/brokenimage.jpg","border_size":10,"font_color":"000","box_color":"fff","top_position":"","overlay_opacity":"0.8","overlay_color":"000","disable_close_click":true,"resize_sequence":0,"resize_speed":400,"fade_in_speed":400,"slide_down_speed":600,"use_alt_layout":false,"disable_resize":false,"disable_zoom":false,"force_show_nav":false,"show_caption":true,"loop_items":false,"node_link_text":"View Image Details","node_link_target":false,"image_count":"Image !current of !total","video_count":"Video !current of !total","page_count":"Page !current of !total","lite_press_x_close":"press \u003Ca href=\u0022#\u0022 onclick=\u0022hideLightbox(); return FALSE;\u0022\u003E\u003Ckbd\u003Ex\u003C\/kbd\u003E\u003C\/a\u003E to close","download_link_text":"","enable_login":false,"enable_contact":false,"keys_close":"c x 27","keys_previous":"p 37","keys_next":"n 39","keys_zoom":"z","keys_play_pause":"32","display_image_size":"original","image_node_sizes":"()","trigger_lightbox_classes":"","trigger_lightbox_group_classes":"","trigger_slideshow_classes":"","trigger_lightframe_classes":"","trigger_lightframe_group_classes":"","custom_class_handler":0,"custom_trigger_classes":"","disable_for_gallery_lists":true,"disable_for_acidfree_gallery_lists":true,"enable_acidfree_videos":true,"slideshow_interval":5000,"slideshow_automatic_start":true,"slideshow_automatic_exit":true,"show_play_pause":true,"pause_on_next_click":false,"pause_on_previous_click":true,"loop_slides":false,"iframe_width":600,"iframe_height":400,"iframe_border":1,"enable_video":false},"views":{"ajax_path":"\/views\/ajax","ajaxViews":{"views_dom_id:ee0e40ee28c621a49eb78f9c7356fa60":{"view_name":"publication_most_read","view_display_id":"block","view_args":"","view_path":"node\/138453","view_base_path":null,"view_dom_id":"ee0e40ee28c621a49eb78f9c7356fa60","pager_element":0}}},"urlIsAjaxTrusted":{"\/views\/ajax":true},"field_group":{"div":"full"}});
//--><!]]>
</script>
<script type="text/javascript">

  var _gaq = _gaq || [];
  _gaq.push(['_setAccount', 'UA-21130176-21']);
  _gaq.push(['_trackPageview']);

  (function() {
    var ga = document.createElement('script'); ga.type = 'text/javascript'; ga.async = true;
    ga.src = ('https:' == document.location.protocol ? 'https://ssl' : 'http://www') + '.google-analytics.com/ga.js';
    var s = document.getElementsByTagName('script')[0]; s.parentNode.insertBefore(ga, s);
  })();

</script>
<script type="text/javascript">

  var _gaq = _gaq || [];
  _gaq.push(['_setAccount', 'UA-21130176-19']);
  _gaq.push(['_setDomainName', 'guardian.co.tt']);
  _gaq.push(['_setAllowLinker', true]);
  _gaq.push(['_trackPageview']);

  (function() {
    var ga = document.createElement('script'); ga.type = 'text/javascript'; ga.async = true;
    ga.src = ('https:' == document.location.protocol ? 'https://ssl' : 'http://www') + '.google-analytics.com/ga.js';
    var s = document.getElementsByTagName('script')[0]; s.parentNode.insertBefore(ga, s);
  })();

</script>
<link rel="shortcut icon" type="image/ico" href="http://www.guardian.co.tt/images/gfavicon.ico" />
<meta http-equiv="X-UA-Compatible" content="IE=edge" />
<meta name="application-name" content="The Trinidad Guardian Newspaper" />
<meta name="msapplication-starturl" content="http://www.guardian.co.tt" />
<meta name="msapplication-navbutton-color" content="#EB1D25" />
<meta name="viewport" content="width=device-width, initial-scale=1.0, maximum-scale=5.0, user-scalable=yes">
<meta name="msapplication-tooltip" content="Start Trinidad Guardian Newspaper" />

</head>
<body class="html not-front not-logged-in two-sidebars page-node page-node- page-node-138453 node-type-articlestory   life-lead">
<div id="search">
<a href="#" class="close">close</a>
<h4> Search </h4>
<div id="search-block-form">
<script>
  (function() {
    var cx = 'partner-pub-4814196096164925:9533398938';
    var gcse = document.createElement('script');
    gcse.type = 'text/javascript';
    gcse.async = true;
    gcse.src = (document.location.protocol == 'https:' ? 'https:' : 'http:') +
        '//www.google.com/cse/cse.js?cx=' + cx;
    var s = document.getElementsByTagName('script')[0];
    s.parentNode.insertBefore(gcse, s);
  })();
</script>
<gcse:search></gcse:search>
</div>
</div>
<div id="page" class="page">

<div id="header">
<div id="logo">
<a href="/" title="Home" rel="home" id="logo">
<img src="http://www.guardian.co.tt/sites/all/themes/publishing/logo.png" alt="Home" />
</a>
</div>
<div id="updated">Last update: 08-Dec-2017 4:36 am<br />
Friday, December 08, 2017<br />
</div>
<div id="social">
<div id="social-media">
<a href="http://guardian.co.tt/sitemap" id="rss" target="_blank"></a>
<a href="https://twitter.com/guardiantt" id="twitter" target="_blank"></a>
<a href="https://www.facebook.com/ttguardian" id="facebook" target="_blank"></a>
<a href="https://plus.google.com/u/0/b/114657292481933475304/" id="googleplus" target="_blank"></a>
<a href="/cdn-cgi/l/email-protection#c5acabb1a0b7aba0b1eba0a1acb1aab785a2b0a4b7a1aca4abeba6aaebb1b1" id="mail" target="_blank"></a>
<p id="site-title">Trinidad & Tobago Guardian Online</p>
</div>
</div>
<div id="header-region">
<div class="region region-header">
<div id="block-block-106" class="block block-block mobile-menu block-odd clearfix">
<div class="block-inner">
<div class="content">
<a href="#" id="menu-button">menu</a> </div>
</div>
</div> <div id="block-menu-menu-short-menu" class="block block-menu no-title block-even clearfix">
<div class="block-inner">
<h2 class="block-title">Short Menu</h2>
<div class="content">
<ul class="menu"><li class="first leaf"><a href="/news">News</a></li>
<li class="leaf"><a href="/sports">Sport</a></li>
<li class="leaf"><a href="/business">Business</a></li>
<li class="leaf mobile-link"><a href="http://www.guardian.co.tt/business-guardian">Business Guardian</a></li>
<li class="leaf"><a href="/lifestyle">Lifestyle</a></li>
<li class="leaf"><a href="/columnists">Columnists</a></li>
<li class="leaf mobile-link"><a href="http://www.guardian.co.tt/Letters">Letters</a></li>
<li class="leaf mobile-link"><a href="http://www.guardian.co.tt/entertainment">Entertainment</a></li>
<li class="leaf"><a href="/editorial">Editorial</a></li>
<li class="leaf mobile-link"><a href="/death-notices">Death Notices</a></li>
<li class="leaf mobile-link"><a href="http://classifieds.guardian.co.tt/RealEstate/Default.aspx" target="_blank">Classifieds</a></li>
<li class="leaf mobile-link"><a href="http://subscriptions.guardian.co.tt/edg/" target="_blank">Digital Guardian</a></li>
<li class="leaf mobile-link"><a href="http://www.guardian.co.tt/archive" target="_blank">Archives</a></li>
<li class="leaf mobile-link"><a href="http://classifieds.guardian.co.tt/RealEstate/Default.aspx" target="_blank">Real Estate</a></li>
<li class="leaf mobile-link"><a href="http://www.guardian.co.tt/digital/subscriptions" target="_blank">Subscriptions</a></li>
<li class="leaf mobile-link"><a href="http://www.guardian.co.tt/your-stories">Your Stories</a></li>
<li class="last leaf mobile-link"><a href="http://iamaguardiantt.tumblr.com/" target="_blank">I am Guardian</a></li>
</ul> </div>
</div>
</div>  </div>
</div>
<ol id="sec-menu">

<li><a id="search-button" href="#">Search</a></li>
</ol>
</div> 
<div id="hidden-menu">
<div class="region region-hidden-menu">
<div id="block-system-user-menu" class="block block-system no-title block-menu block-odd clearfix">
<div class="block-inner">
<h2 class="block-title">User menu</h2>
<div class="content">
<ul class="menu"><li class="first leaf"><a href="/business-guardian">Business Guardian</a></li>
<li class="leaf"><a href="/entertainment">Entertainment</a></li>
<li class="leaf"><a href="/Letters">Letters</a></li>
<li class="leaf"><a href="/death-notices">Death Notices</a></li>
<li class="leaf"><a href="http://www.guardian.co.tt/archive">Archives</a></li>
<li class="leaf"><a href="http://classifieds.guardian.co.tt/RealEstate/Default.aspx">Real Estate</a></li>
<li class="leaf"><a href="http://classifieds.guardian.co.tt/" target="_blank">Classifieds</a></li>
<li class="leaf no-mobile"><a href="http://www.guardian.co.tt/digital/subscriptions" target="_blank">Subscriptions</a></li>
<li class="leaf no-mobile"><a href="http://iamaguardiantt.tumblr.com/" target="_blank">I am Guardian</a></li>
<li class="last leaf"><a href="http://www.guardian.co.tt/sea">SEA Math</a></li>
</ul> </div>
</div>
</div>  </div>
</div>
<div id="banner">
<div class="region region-banner">
<div id="block-block-11" class="block block-block top-ad desktopad ads728 cell-lg-7 block-even clearfix">
<div class="block-inner">
<div class="content">
<center><iframe src="http://www.guardian.co.tt/adcode/leaderboard.html" frameborder="0" width="728" height="90" style="padding:0; margin:0;" scrolling="no"></iframe></center> </div>
</div>
</div> <div id="block-block-63" class="block block-block digital-ad desktopad  cell-lg-5 block-odd clearfix">
<div class="block-inner">
<div class="content">
<center><iframe src="http://www.guardian.co.tt/adcode/headersmall.html" frameborder="0" width="450" height="90" style="padding:0; margin:0;" scrolling="no"></iframe></center> </div>
</div>
</div> <div id="block-block-107" class="block block-block ads600 mobileads block-even clearfix">
<div class="block-inner">
<div class="content">
<script data-cfasync="false" src="/cdn-cgi/scripts/af2821b0/cloudflare-static/email-decode.min.js"></script><script type='text/javascript'>
  var googletag = googletag || {};
  googletag.cmd = googletag.cmd || [];
  (function() {
    var gads = document.createElement('script');
    gads.async = true;
    gads.type = 'text/javascript';
    var useSSL = 'https:' == document.location.protocol;
    gads.src = (useSSL ? 'https:' : 'http:') +
      '//www.googletagservices.com/tag/js/gpt.js';
    var node = document.getElementsByTagName('script')[0];
    node.parentNode.insertBefore(gads, node);
  })();
</script>
<script type='text/javascript'>
  googletag.cmd.push(function() {
    googletag.defineSlot('/103800131/mobile600', [600, 100], 'div-gpt-ad-1466003545412-0').addService(googletag.pubads());
    googletag.pubads().enableSingleRequest();
    googletag.pubads().collapseEmptyDivs();
    googletag.enableServices();
  });
</script>

<div id='div-gpt-ad-1466003545412-0' style='height:100px; width:600px; margin:0 auto;'>
<script type='text/javascript'>
googletag.cmd.push(function() { googletag.display('div-gpt-ad-1466003545412-0'); });
</script>
</div> </div>
</div>
</div> <div id="block-block-108" class="block block-block ads320 mobileads block-odd clearfix">
<div class="block-inner">
<div class="content">
<script type='text/javascript'>
  var googletag = googletag || {};
  googletag.cmd = googletag.cmd || [];
  (function() {
    var gads = document.createElement('script');
    gads.async = true;
    gads.type = 'text/javascript';
    var useSSL = 'https:' == document.location.protocol;
    gads.src = (useSSL ? 'https:' : 'http:') +
      '//www.googletagservices.com/tag/js/gpt.js';
    var node = document.getElementsByTagName('script')[0];
    node.parentNode.insertBefore(gads, node);
  })();
</script>
<script type='text/javascript'>
  googletag.cmd.push(function() {
    googletag.defineSlot('/103800131/mobile320', [320, 90], 'div-gpt-ad-1467390568976-0').addService(googletag.pubads());
    googletag.pubads().enableSingleRequest();
    googletag.pubads().collapseEmptyDivs();
    googletag.enableServices();
  });
</script>

<div id='div-gpt-ad-1467390568976-0' style='height:90px; width:320px; margin:0 auto;'>
<script type='text/javascript'>
googletag.cmd.push(function() { googletag.display('div-gpt-ad-1467390568976-0'); });
</script>
</div> </div>
</div>
</div>  </div>
</div>

<div id="main" class="clearfix">
<div id="content">
<div id="content-inner" class="inner column center">
<div id="content-header">
<h2 class="element-invisible">You are here</h2><div class="breadcrumb"><a href="/">Home</a></div>
<div class="strapandslug"></div>
<h1 class="title">Sokah, parang and steel heats up wet weekend</h1>
<div class="tabs"></div>
</div> 

<div id="content-area">
<div class="region region-content">
<ul id="sharebarp" style="background:#FFFFFF;border-color:#ffffff;margin-top:10px;width: 350px; float: left; margin-right:-20pxpx;"><li>
<g:plusone></g:plusone>

<script type="text/javascript">
  (function() {
    var po = document.createElement('script'); po.type = 'text/javascript'; po.async = true;
    po.src = 'https://apis.google.com/js/plusone.js';
    var s = document.getElementsByTagName('script')[0]; s.parentNode.insertBefore(po, s);
  })();
</script></li><li><a href="https://twitter.com/share" class="twitter-share-button" data-count="horizontal" data-via="guardiantt">Tweet</a><script type="text/javascript" src="https://platform.twitter.com/widgets.js"></script></li><li><iframe src="https://www.facebook.com/plugins/like.php?href=http://www.guardian.co.tt/life-lead/2017-12-08/sokah-parang-and-steel-heats-wet-weekend&layout=button_count&show_faces=false&width=85&action=like&colorscheme=light&height=21" scrolling="no" frameborder="0" style="border:none; overflow:hidden; width:85px; height:21px;" allowTransparency="true"></iframe></li></ul><div id="block-system-main" class="block block-system block-even clearfix">
<div class="block-inner">
<div class="content">
<div id="node-138453" class="node node-articlestory node-promoted node-odd">
<div class="node-inner">
<div class="desktopads ads600">
<center>
<script async src="//pagead2.googlesyndication.com/pagead/js/adsbygoogle.js"></script>

<ins class="adsbygoogle" style="display:inline-block;width:580px;height:90px" data-ad-client="ca-pub-4814196096164925" data-ad-slot="4646641906"></ins>
<script>
        (adsbygoogle = window.adsbygoogle || []).push({});
        </script>
</center>
</div>
<div class="content">
<div id=content-read>
<div class="field field-name-field-authors field-type-taxonomy-term-reference field-label-hidden"><div class="field-items"><div class="field-item even"><a href="/byline-authors/peter-ray-blood" typeof="skos:Concept" property="rdfs:label skos:prefLabel" datatype="">Peter Ray Blood</a></div></div></div><div class="field field-name-field-date field-type-datetime field-label-inline clearfix"><div class="field-label">Published:&nbsp;</div><div class="field-items"><div class="field-item even"><span class="date-display-single" property="dc:date" datatype="xsd:dateTime" content="2017-12-08T00:00:00-04:00">Friday, December 8, 2017</span></div></div></div><div class="field field-name-field-strap field-type-text field-label-hidden"><div class="field-items"><div class="field-item even">Pulse</div></div></div><div class="group-image field-group-div"><div class="field field-name-field-image field-type-image field-label-hidden"><div class="field-items"><div class="field-item even"><img typeof="foaf:Image" src="http://www.guardian.co.tt/sites/default/files/field/image/parang%20pulse.jpg" width="400" height="246" alt="" /></div></div></div></div><div class="field field-name-body field-type-text-with-summary field-label-hidden"><div class="field-items"><div class="field-item even" property="content:encoded"><p>With a full moon approaching there was water everywhere but people drank sumptuously from the flood of entertainment taking place nationwide. On Saturday, Yorke Inc held yet another bumper happening at the Salybia Nature Resort &amp; Spa, venue for its annual Wild Meat Soca Parang Food Festival. Artistes like Road March champ MX Prime, Scrunter, Baron, Kenny J, and DJs Howie T, Sounds of Kabuki and Duane kept patrons dancing until way after the party’s scheduled midnight completion.</p>
<p>Also taking its crowd way into Sunday morning was Pan in D Rosa 7, staged by the Pan in D Rosa Committee and Tunapuna/Piarco Regional Corporation at Lime Boulevard, Santa Rosa Heights, Arima. Desperadoes, First Citizens Supernovas, bpTT Renegades, Republic Bank Exodus, PCS Nitrogen Silver Stars, CAL Invaders and San City Steel Symphony were just some of the steelbands that graced the occasion.</p>
<p>Down South, Nialah Blackman had a successful launching of her debut album (Sokah) while back in the north it was Parang &amp; Steel hosted by PCS Nitrogen Silver Stars in Newtown.</p>
<p>What can be said of Nialah’s premiere release? Her sound reflects the evolution of the genre, but stays true to its fundamental ethos as the “Soul of Calypso.”</p>
<p>In a pre-show interview she said, “It’s the unity of cultures, bringing people together. Soca is togetherness, peace, love and harmony among all the races.”</p>
<p>Nialah wants soca to be the sound of the future of T&amp;T and, based on the audience’s response last weekend she will keep her promise, “This concert is going to be an annual event. It will be a platform for young people to showcase their culture. Sometimes we can get lost in the influences of other genres and cultures, but we need to respect ours.”</p>
<p>The granddaughter of late soca pioneer Ras Shorty I and daughter of 1979 National Calypso Queen Abbi Blackman, this drop-dead-gorgeous and talented soca princess is well poised and on her way to ascending to the pinnacle of the genre.</p>
<p>Last Sunday was just a wee bit more sedate although patrons were seen dancing up a storm at the Paragon Sports &amp; Cultural Club’s annual Parang &amp; Soca Luncheon in Cocorite. Headlining this gig were Marcia Miranda, Los Vikingos de San Jose and DJ Cardo.</p>
<p>Rounding off a weekend of non-stop entertainment action was the annual parang festival in Lopinot.</p>
<p>This weekend is no different and fingers are crossed that the weather is kinder, especially for the many outdoor events. This evening Newtown Playboyz holds It’s A Sweet Parang Soca Lime at its Pan Theatre on Tragarete Road, from 6 pm. Live performances will come from Pelham Goddard &amp; Roots, Los Angeles de San Miguel, Marilyn Williams, Moricia Cagan, Nigel O’Connor and host Newtown Playboyz.</p>
<p>Prayers are being offered for clear skies tomorrow evening as well when Republic Bank stages A Gift of Love, featuring The Love Movement, Adam Smith Square, Woodbrook, at 6 pm.</p>
<p>Southern action includes the High Commission of India and the Mahatma Gandhi Institute for Cultural Co-operation, in collaboration with Ministry of Community Development, Culture and the Arts, staging Rhythms of Manipur from 6.30 pm. This will be held in Fyzabad at the Shri Siddhi Vinayaaka Avocat Mandir, on 296 Siparia Old Road, Avocat Village.</p>
<p>I Dream A World, featuring bpTT Marionettes, is on</p>
<p>• Continues on Page B10</p>
<p>• From Page B9</p>
<p> </p>
<p>at Queen’s Hall, and The True Meaning of Christmas, featuring T&amp;T Youth Philharmonic (TTYP), Voices of The University School (VOUS) children’s choir and Euangelion Singers and Band will be staged at the National Academy for the Performing Arts (Napa), Port-of-Spain. These two concerts begin at 7.30 pm.</p>
<p>The second instalment of Parang &amp; Steel 2017 will also be held tomorrow at Silver Stars and, in St James, on Mooneram Street, Cheers Pub will holds its lively Parang, Pork &amp; Pan, featuring The Love Bunch parang group, Sapophonics Steel, The Stella Band and more.</p>
<p>Rock band jointpop is also in concert tomorrow at All Out Lounge, Queen’s Park Oval, Tragarete Road, Woodbrook with its Noise n Toys benefit.</p>
<p>For the past 13 years, jointpop hosts and performs at this toy collection concert. The show also doubles as the jointpop Christmas office party and it is always well attended and a fun filled night.</p>
<p>This will be the last jointpop gig of 2017 as the band is heading to the recording studio next Wednesday, until December 22 to record it’s eighth album, to be released in 2018. Recording will be done at STUDIO 303, the UTT studio at Napa.</p>
<p>Top Seattle-based producer Paul Kimble will be on board again , to follow up the production he did on the last jointpop album Quicksand (2015). Kimble is the bassist and producer of legendary US band Grant Lee Buffalo. MusicTT has assisted jointpop with funding for the album recording.</p>
<p>Also performing tomorrow night will be The Malcontents.</p>
<p>The Noise and Toys concert costs $80 entry at the door, plus a gift wrapped toy with a label or note with the information of gender and the age group of the child. All the toys are collected on the night and then distributed to various unprivileged kids homes across the country. Remember the one and most important rule of entry: No Toy Guns please.</p>
<p>Things cool down on Sunday evening with T&amp;T Youth Philharmonic (TTYP), Voices of The University School (VOUS) children’s choir and Euangelion Singers and Band at Napa, Port-of-Spain; and, The Marionettes’ I Dream A World finale at Queen’s Hall, St Ann’s.</p>
<p> </p>
<p>Christmas with the Saints 2</p>
<p> </p>
<p>The students of St Mary’s College are embarking for a second year on their Christmas production Christmas with the Saints 2, to be at the college’s Centenary Hall on Pembroke Street, Port-of-Spain. This event is organised by Form Six students and will serve as a glorious night of entertainment for the parents, teachers and students of St Mary’s College, and to the wider public who wish to enjoy a Saturday night of music and performance.</p>
<p>The concert brings out the best of the school’s present talent, including award-winning calypsonians Desle Julien, Duane O’Connor, Renaldo Alleyne-Noreiga and Reshawn Goodridge. The event also incorporates the talents of past students like vocalist Jake Salloum and instrumentalist Luke Walker.</p>
<p>Besides solo performers like these, patrons can expect to be wowed by the school’s parang side Los Santos whose recent victories include placing third in the National Junior Parang Competition.</p>
<p>The concert will similarly place emphasis on our national instrument, showcasing the college’s incomparable pan-side The Symphony of Saints, among pan soloists like Dylan Yuk Low.</p>
<p>At the admission fee of a mere blue note ($100) this show is a steal-of-a-deal if ever there was one, especially with its star-studded retinue of guest performers. Guest artistes include Parang Queen Alicia Jaggassar and Los Alumnos de San Juan, 3Canal, The Flick, Ms Dija, Shortpants, Mastertone Salloum and La Nueva Experiencia.</p>
<p>Jake Salloum is the creative director of Christmas with the Saints 2 and its musical director is Alea Jaggernauth. The show is produced entirely by the Form 6 Students of St. Mary’s College.</p>
<p>Christmas Delicacies (fruit cake, pastelles etc) and drinks (sorrel, ponche de crème etc.) will be on sale and tickets are are available at the college’s office, or through Manager Enrico Rajah (623-8835/745-4391). Showtime is 7.30 pm.</p>
<p>All proceeds go towards recurrent expenditure and the Music Room.</p>
</div></div></div><div class="field field-name-field-topic field-type-taxonomy-term-reference field-label-hidden"><div class="field-items"><div class="field-item even"><a href="/topic/life-lead" typeof="skos:Concept" property="rdfs:label skos:prefLabel" datatype="">Life Lead</a></div></div></div> </div>
<div id='node_nav'><strong><div class="next_link">Next Article<br /><a href="/life-lead/2017-12-07/civilian-conservation-corps-makes-style">Civilian Conservation Corps makes style</a></div></strong></div></div>
<div class="desktopads ads600">
<center>
<script async src="//pagead2.googlesyndication.com/pagead/js/adsbygoogle.js"></script>

<ins class="adsbygoogle" style="display:inline-block;width:580px;height:90px" data-ad-client="ca-pub-4814196096164925" data-ad-slot="4646641906"></ins>
<script>
        (adsbygoogle = window.adsbygoogle || []).push({});
        </script>
</center>
</div>
<div class="links"></div>
</div> 
</div> 
</div>
</div>
</div> <div id="block-block-117" class="block block-block block-odd clearfix">
<div class="block-inner">
<div class="content">
<script async src="https://recirculation.spot.im/spot/sp_XC61vFgU"></script> <div data-spotim-module="recirculation" data-spot-id="sp_XC61vFgU"></div><script async data-spotim-module="spotim-launcher" src="https://launcher.spot.im/spot/sp_XC61vFgU" data-post-id="Sokah, parang and steel heats up wet weekend"></script> </div>
</div>
</div>  </div>
</div>
</div>
</div> 


<div id="sidebar-first" class="column sidebar first">
<div id="sidebar-first-inner" class="inner">
<div class="region region-sidebar-first">
<div id="block-views-publication_most_read-block" class="block block-views internal-popular no-mobile block-even clearfix">
<div class="block-inner">
<h2 class="block-title">In case you missed it.</h2>
<div class="content">
<div class="view view-publication-most-read view-id-publication_most_read view-display-id-block view-dom-id-ee0e40ee28c621a49eb78f9c7356fa60">
<div class="view-content">
<table class="views-view-grid cols-1">
<tbody>
<tr class="row-1 row-first">
<td class="col-1 col-first">
<div class="views-field views-field-title"> <span class="field-content"><a href="/sports/2017-12-08/hollie-get-her-%E2%80%98stripes">Hollie to get her ‘Stripes</a></span> </div>
<div class="views-field views-field-field-image"> <div class="field-content"><img typeof="foaf:Image" src="http://www.guardian.co.tt/sites/default/files/styles/thumbnail/public/field/image/jeff_45.jpg?itok=SYbkQU-t" width="78" height="100" alt="" /></div> </div>
<div class="views-field views-field-body"> <div class="field-content"><p>Hilborough ticks enough boxes, and it certainly wont be a surprise if Mick Channon’s charge causes one, in the nine-runner Novice Stakes over seven furlongs of Chelmsford polytrack tonight; I’m...</div> </div> </td>
</tr>
<tr class="row-2">
<td class="col-1 col-first">
<div class="views-field views-field-title"> <span class="field-content"><a href="/sports/2017-12-07/%E2%80%98dragons%E2%80%99-worth-investment">‘Dragons’ worth investment</a></span> </div>
<div class="views-field views-field-field-image"> <div class="field-content"><img typeof="foaf:Image" src="http://www.guardian.co.tt/sites/default/files/styles/thumbnail/public/field/image/jeff_44.jpg?itok=YUDfoOoe" width="78" height="100" alt="" /></div> </div>
<div class="views-field views-field-body"> <div class="field-content"><p>Mother Of Dragons, unlucky five days ago over six furlongs of Chelmsford polytrack, drops back to the minimum trip for another Nursery Handicap at the Essex course today; apprentice Nicola Currie...</div> </div> </td>
</tr>
<tr class="row-3">
<td class="col-1 col-first">
<div class="views-field views-field-title"> <span class="field-content"><a href="/life-lead/2017-12-07/civilian-conservation-corps-makes-style">Civilian Conservation Corps makes style</a></span> </div>
<div class="views-field views-field-field-image"> <div class="field-content"><img typeof="foaf:Image" src="http://www.guardian.co.tt/sites/default/files/styles/thumbnail/public/field/image/doing%20heai.jpg?itok=NgBdTO8w" width="100" height="98" alt="" /></div> </div>
<div class="views-field views-field-body"> <div class="field-content"><p>Last Saturday, Civilian Conservation Corps (CCC) held its Hair, Make up and Nails styling competition at its headquarters on Mausica Road.</p></div> </div> </td>
</tr>
<tr class="row-4">
<td class="col-1 col-first">
<div class="views-field views-field-title"> <span class="field-content"><a href="/sports/2017-12-07/money-woes-hamper-boxers%E2%80%99-travel">Money woes hamper boxers’ travel</a></span> </div>
<div class="views-field views-field-field-image"> <div class="field-content"><img typeof="foaf:Image" src="http://www.guardian.co.tt/sites/default/files/styles/thumbnail/public/field/image/cecil.jpg?itok=hS7JLhPi" width="92" height="100" alt="" /></div> </div>
<div class="views-field views-field-body"> <div class="field-content"><p>There were mixed emotions when the sport of boxing concluded its programme for the year at the Cosmic Boxing Gym in Marabella on Saturday.</p></div> </div> </td>
</tr>
<tr class="row-5">
<td class="col-1 col-first">
<div class="views-field views-field-title"> <span class="field-content"><a href="/news/2017-12-07/they-wont-act-save-lives">They wont act to save lives</a></span> </div>
<div class="views-field views-field-field-image"> <div class="field-content"><img typeof="foaf:Image" src="http://www.guardian.co.tt/sites/default/files/styles/thumbnail/public/field/image/pm%20rowley.jpg?itok=wv5w5HrS" width="100" height="78" alt="" /></div> </div>
<div class="views-field views-field-body"> <div class="field-content"><p>More people in T&amp;T will die as a result of the Opposition United National Congress’ refusal to support the anti-gang bill in Parliament yesterday, Prime Minister Dr Keith Rowley has said.</p></div> </div> </td>
</tr>
<tr class="row-6">
<td class="col-1 col-first">
<div class="views-field views-field-title"> <span class="field-content"><a href="/sports/2017-12-08/estwick-brathwaite-ideal-replacement-captain">Estwick: Brathwaite an ideal replacement as captain</a></span> </div>
<div class="views-field views-field-field-image"> <div class="field-content"><img typeof="foaf:Image" src="http://www.guardian.co.tt/sites/default/files/styles/thumbnail/public/field/image/bwait.jpg?itok=wIbHU1U6" width="100" height="75" alt="" /></div> </div>
<div class="views-field views-field-body"> <div class="field-content"><p>HAMILTON, New Zealand—Assistant coach Roddy Estwick believes Kraigg Brathwaite will acquit himself well, when he takes over as West Indies captain for the second Test against the Black Caps...</div> </div> </td>
</tr>
<tr class="row-7">
<td class="col-1 col-first">
<div class="views-field views-field-title"> <span class="field-content"><a href="/news/2017-12-06/eoc-head-calls-laws-against-sexual-harassment">EOC head calls for laws against sexual harassment</a></span> </div>
<div class="views-field views-field-field-image"> <div class="field-content"><img typeof="foaf:Image" src="http://www.guardian.co.tt/sites/default/files/styles/thumbnail/public/neoimages/833457.jpg?itok=cWkHAQtG" width="100" height="67" alt="" /></div> </div>
<div class="views-field views-field-body"> <div class="field-content"><p>Even if a company has the best policy against sexual harassment in the workplace, if it is not supported by upper management, all attempts to safeguard employees will be in vain, chairman of the...</div> </div> </td>
</tr>
<tr class="row-8">
<td class="col-1 col-first">
<div class="views-field views-field-title"> <span class="field-content"><a href="/news/2017-12-07/williams-bans-extra-duty-cops">Williams bans extra duty for cops</a></span> </div>
<div class="views-field views-field-field-image"> <div class="field-content"><img typeof="foaf:Image" src="http://www.guardian.co.tt/sites/default/files/styles/thumbnail/public/field/image/Acting%20Police%20Commissioner%20Stephen%20Williams_1.jpg?itok=5mzb3Vsi" width="92" height="100" alt="" /></div> </div>
<div class="views-field views-field-body"> <div class="field-content"><p>A directive from acting Commissioner of Police Stephen Williams to stop all extra duty is not sitting well with his junior charges, who say the money the make from this is what they use to pay the...</div> </div> </td>
</tr>
<tr class="row-9">
<td class="col-1 col-first">
<div class="views-field views-field-title"> <span class="field-content"><a href="/news/2017-12-06/gunmen-execute-woman-front-husband">Gunmen execute woman in front husband</a></span> </div>
<div class="views-field views-field-field-image"> <div class="field-content"><img typeof="foaf:Image" src="http://www.guardian.co.tt/sites/default/files/styles/thumbnail/public/field/image/Alicia%20Mohammed.jpg?itok=-V1WDtof" width="83" height="100" alt="" /></div> </div>
<div class="views-field views-field-body"> <div class="field-content"><p>A 47-year-old woman was among four people killed over another 24-hour period as the murder toll rose to 466.</p></div> </div> </td>
</tr>
<tr class="row-10 row-last">
<td class="col-1 col-first">
<div class="views-field views-field-title"> <span class="field-content"><a href="/news/2017-12-07/gang-alliances-politicians-evil-monster-%E2%80%94-deosaran">Gang alliances with politicians an evil monster — Deosaran</a></span> </div>
<div class="views-field views-field-field-image"> <div class="field-content"><img typeof="foaf:Image" src="http://www.guardian.co.tt/sites/default/files/styles/thumbnail/public/field/image/matress.jpg?itok=b4MAnoVq" width="95" height="100" alt="" /></div> </div>
<div class="views-field views-field-body"> <div class="field-content"><p>Chairman of the Manpower Audit Committee into the T&amp;T Police Service (TTPS), Prof Ramesh Deosaran, yesterday said the alliances between politicians, gang leaders and community leaders have...</div> </div>  </td>
</tr>
</tbody>
</table>
</div>
</div> </div>
</div>
</div>  </div>
</div>
</div>

<div id="sidebar-second" class="column sidebar second">
<div id="sidebar-second-inner" class="inner">
<div class="region region-sidebar-second">
<div id="block-block-97" class="block block-block advertisment ads block-odd clearfix">
<div class="block-inner">
<div class="content">
<script async='async' src='https://www.googletagservices.com/tag/js/gpt.js'></script>
<script>
  var googletag = googletag || {};
  googletag.cmd = googletag.cmd || [];
</script>
<script>
  googletag.cmd.push(function() {
    googletag.defineSlot('/103800131/Guardian300x250', [300, 250], 'div-gpt-ad-1506623274501-0').addService(googletag.pubads());
    googletag.pubads().enableSingleRequest();
    googletag.pubads().collapseEmptyDivs();
    googletag.enableServices();
  });
</script>

<div id='div-gpt-ad-1506623274501-0' style='height:250px; width:300px;'>
<script>
googletag.cmd.push(function() { googletag.display('div-gpt-ad-1506623274501-0'); });
</script>
</div> </div>
</div>
</div> <div id="block-block-98" class="block block-block advertisment ads block-even clearfix">
<div class="block-inner">
<div class="content">
<center><iframe src="http://www.guardian.co.tt/adcode/sidebar2.html" width="300" height="250" style="padding:0; margin:0; border:none; overflow:hidden" scrolling="no"></iframe></center> </div>
</div>
</div> <div id="block-block-9" class="block block-block advertisment google block-odd clearfix">
<div class="block-inner">
<div class="content">
<center>
<script async src="//pagead2.googlesyndication.com/pagead/js/adsbygoogle.js"></script>

<ins class="adsbygoogle" style="display:inline-block;width:300px;height:250px" data-ad-client="ca-pub-4814196096164925" data-ad-slot="3725503905"></ins>
<script>
(adsbygoogle = window.adsbygoogle || []).push({});
</script>
</center> </div>
</div>
</div>  </div>
</div>
</div>

</div> 

<div id="footer_bottom">
<div class="region region-footer-bottom">
<div id="block-block-62" class="block block-block gml-logo left block-even clearfix">
<div class="block-inner">
<div class="content">
<p><a href="http://corp.guardian.co.tt" target="_blank"><img alt="" src="data:image/png;base64,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" style="margin:5px 10px" /></a></p>
		</div>

  </div>
</div> <!-- /block-inner /block --><div id="block-block-6" class="block block-block disclaimer right block-odd clearfix">
  <div class="block-inner">

                		
		<div class="content" >
		  <p>GUARDIAN MEDIA is not responsible for the content of external sites. Copyright © 2014 GUARDIAN MEDIA LIMITED</p>
		</div>

  </div>
</div> <!-- /block-inner /block --><div id="block-menu-menu-footer-links" class="block block-menu footer_menu right block-even clearfix">
  <div class="block-inner">

                <h2 class="block-title">Footer links</h2>
          		
		<div class="content" >
		  <ul class="menu"><li class="first leaf"><a href="http://www.guardian.co.tt/annual-reports" target="_blank">Annual Reports</a></li>
<li class="leaf"><a href="/contact">Contact Us</a></li>
<li class="leaf"><a href="http://www.guardian.co.tt/archive">Archives</a></li>
<li class="leaf"><a href="http://www.guardian.co.tt/advertisewithus">E-Advertise with us</a></li>
<li class="leaf"><a href="/terms-of-services">Terms of Service</a></li>
<li class="leaf"><a href="/privacy">Privacy</a></li>
<li class="leaf"><a href="http://www.guardian.co.tt/rss.xml">RSS</a></li>
<li class="last leaf"><a href="/sitemap">Sitemap</a></li>
</ul>		</div>

  </div>
</div> <!-- /block-inner /block -->  </div>
    </div> <!-- /footer -->
  
</div> <!-- /page -->
  <script type="text/javascript" src="http://www.guardian.co.tt/sites/all/modules/block_refresh/js/block_refresh.js?p0e5yl"></script>
</body>
</html>
