<!doctype html>
<html>
<head>
<script src="/cdn-cgi/apps/head/BiIkTUgOkEb3mzQGgTjTNQncU0A.js"></script><script type='text/javascript'>var _sf_startpt=(new Date()).getTime()</script>
<meta http-equiv="Content-Type" content="text/html; charset=utf-8" />
<link rel="shortcut icon" href="http://www.guardian.co.tt/sites/default/files/guardianfav1.ico" type="image/vnd.microsoft.icon" />
<meta name="keywords" content="News" />
<meta name="description" content="Western Division police have arrested eight men in relation to the seizure of four illegal firearms, this week.
Police arrested five of the suspects on Monday after they stopped their Nissan B15 along the Western Main Road in Westmoorings.
Police found a" />
<meta name="description" content="Western Division police have arrested eight men in relation to the seizure of four illegal firearms, this week. Police arrested five of the suspects on Monday after they stopped their Nissan B15 along the Western Main Road in Westmoorings. Police found a loaded Glock 17 pistol with 11 rounds of 9 mm ammunition. The gun was also outfitted with a selector which allows the user to fire automatic bursts from the semi-automatic pistol. The suspects, ages 18 to 21, all from Factory Road in Diego Martin were arrested. Almost 24 hours later, officers of the Western Division Task Force (WDTF) led by Sgt Ulric Arneaud were on patrol in Richplain, Diego Martin, when they observed three armed men in a bushy area. The men attempted to run away but were arrested. The officers recovered an FX-9 machine gun, a 12-gauge pump action shotgun, a Glock pistol and 14 rounds of assorted ammunition. The pistol was also outfitted with a selector. The eight suspects remained detained up to late yesterday and are expected to be taken to court today." />
<meta name="rating" content="general" />
<meta name="generator" content="Drupal 7 (http://drupal.org)" />
<link rel="image_src" href="http://www.guardian.co.tt/sites/default/files/field/image/guns%20big.jpg" />
<link rel="canonical" href="http://www.guardian.co.tt/news/2018-08-30/eight-arrested-four-guns-seized-west-trinidad" />
<meta property="fb:admins" content="559680181" />
<meta property="og:type" content="website" />
<meta property="og:site_name" content="The Trinidad Guardian Newspaper" />
<meta property="og:url" content="http://www.guardian.co.tt/news/2018-08-30/eight-arrested-four-guns-seized-west-trinidad" />
<meta property="og:title" content="Eight arrested as four guns seized in west Trinidad" />
<meta property="og:description" content="Western Division police have arrested eight men in relation to the seizure of four illegal firearms, this week. Police arrested five of the suspects on Monday after they stopped their Nissan B15 along the Western Main Road in Westmoorings. Police found a loaded Glock 17 pistol with 11 rounds of 9 mm ammunition. The gun was also outfitted with a selector which allows the user to fire automatic bursts from the semi-automatic pistol. The suspects, ages 18 to 21, all from Factory Road in Diego Martin were arrested. Almost 24 hours later, officers of the Western Division Task Force (WDTF) led by Sgt Ulric Arneaud were on patrol in Richplain, Diego Martin, when they observed three armed men in a bushy area. The men attempted to run away but were arrested. The officers recovered an FX-9 machine gun, a 12-gauge pump action shotgun, a Glock pistol and 14 rounds of assorted ammunition. The pistol was also outfitted with a selector. The eight suspects remained detained up to late yesterday and are expected to be taken to court today." />
<meta property="og:updated_time" content="2018-08-30T06:17:55-04:00" />
<meta property="og:image" content="http://www.guardian.co.tt/sites/default/files/field/image/guns%20big.jpg" />
<meta name="twitter:card" content="summary_large_image" />
<meta name="twitter:creator" content="@guardiantt" />
<meta name="twitter:creator:id" content="48003020" />
<meta name="twitter:title" content="Eight arrested as four guns seized in west Trinidad" />
<meta name="twitter:description" content="Western Division police have arrested eight men in relation to the seizure of four illegal firearms, this week. Police arrested five of the suspects on Monday after they stopped their Nissan B15 along the Western Main Road in Westmoorings. Police found a loaded Glock 17 pistol with 11 rounds of 9 mm ammunition. The gun was also outfitted with a selector which allows the user to fire automatic bursts from the semi-automatic pistol. The suspects, ages 18 to 21, all from Factory Road in Diego Martin were arrested. Almost 24 hours later, officers of the Western Division Task Force (WDTF) led by Sgt Ulric Arneaud were on patrol in Richplain, Diego Martin, when they observed three armed men in a bushy area. The men attempted to run away but were arrested. The officers recovered an FX-9 machine gun, a 12-gauge pump action shotgun, a Glock pistol and 14 rounds of assorted ammunition. The pistol was also outfitted with a selector. The eight suspects remained detained up to late yesterday and are expected to be taken to court today." />
<meta name="twitter:image" content="http://www.guardian.co.tt/sites/default/files/field/image/guns%20big.jpg" />
<meta property="article:published_time" content="2018-08-30T06:17:55-04:00" />
<meta property="article:modified_time" content="2018-08-30T06:17:55-04:00" />
<meta itemprop="name" content="Eight arrested as four guns seized in west Trinidad" />
<meta itemprop="description" content="Western Division police have arrested eight men in relation to the seizure of four illegal firearms, this week. Police arrested five of the suspects on Monday after they stopped their Nissan B15 along the Western Main Road in Westmoorings." />
<title>Eight arrested as four guns seized in west Trinidad | The Trinidad Guardian Newspaper</title>
<link type="text/css" rel="stylesheet" href="http://www.guardian.co.tt/sites/default/files/css/css_xE-rWrJf-fncB6ztZfd2huxqgxu4WO-qwma6Xer30m4.css" media="all" />
<link type="text/css" rel="stylesheet" href="http://www.guardian.co.tt/sites/default/files/css/css_dOhuNZJFrahWaLVt5TX99Cxv3rFN7c08CsNkW8Qj1ws.css" media="all" />
<link type="text/css" rel="stylesheet" href="http://www.guardian.co.tt/sites/default/files/css/css_TyFqS_ULCKW6Xo_yfumCcNjJeWrx2mBXamKw42WSlFU.css" media="all" />
<link type="text/css" rel="stylesheet" href="http://www.guardian.co.tt/sites/default/files/css/css_5wfXOWVzB54BcGhlhAcevQ4dJIYgEPZEKFH3-thh1BI.css" media="all" />
<script type="text/javascript" src="//code.jquery.com/jquery-1.7.2.js"></script>
<script type="text/javascript">
<!--//--><![CDATA[//><!--
window.jQuery || document.write("<script src='/sites/all/modules/jquery_update/replace/jquery/1.7/jquery.js'>\x3C/script>")
//--><!]]>
</script>
<script type="text/javascript" src="http://www.guardian.co.tt/sites/default/files/js/js_DRszCILfNteakMtA9IaG5VfXMgclPUg36cL1gyTDqJk.js"></script>
<script type="text/javascript" src="http://www.guardian.co.tt/sites/default/files/js/js_9onouvIoBbig13lHXjy3jwR9b7Zs_iZ_Ve_2hJju0gs.js"></script>
<script type="text/javascript" src="http://www.guardian.co.tt/sites/default/files/js/js_DG0_i9to4jdZTwjB2N4pEwU3vzp3DnLHFJHHqayeUkM.js"></script>
<script type="text/javascript" src="http://www.guardian.co.tt/sites/all/modules/lightbox2/js/lightbox.js?1535628291"></script>
<script type="text/javascript" src="http://www.guardian.co.tt/sites/default/files/js/js_CfV6dNIvVYTY8Inrun7WYOemJQRdt1E1aLirxPGIQWA.js"></script>
<script type="text/javascript" src="http://www.guardian.co.tt/sites/default/files/js/js_PbzSuJhx0LotUBNgcU1CCaQ4VZCdzL1XIzZivTxwheI.js"></script>
<script type="text/javascript">
<!--//--><![CDATA[//><!--
!function(t,e,n){function a(t){var a=e.createElement("script");a.type="text/javascript",a.async=!0,a.src=("https:"===e.location.protocol?"https":"http")+":"+n,(t||e.body||e.head).appendChild(a)}function o(){var t=e.getElementsByTagName("script"),n=t[t.length-1];return n.parentNode} var p=o();t.spotId="sp_XC61vFgU",t.parentElement=p,a(p)}(window.SPOTIM={},document,"//www.spot.im/launcher/bundle.js");
//--><!]]>
</script>
<script type="text/javascript">
<!--//--><![CDATA[//><!--
jQuery.extend(Drupal.settings, {"basePath":"\/","pathPrefix":"","ajaxPageState":{"theme":"publishing","theme_token":"9-AtlqeUhLSVCd_Lg9keorGehgUZbmyeY_yy47zhdO4","jquery_version":"1.7","js":{"\/\/code.jquery.com\/jquery-1.7.2.js":1,"0":1,"misc\/jquery.once.js":1,"misc\/drupal.js":1,"sites\/all\/modules\/jquery_update\/replace\/ui\/external\/jquery.cookie.js":1,"sites\/all\/modules\/jquery_update\/replace\/misc\/jquery.form.js":1,"misc\/ajax.js":1,"sites\/all\/modules\/jquery_update\/js\/jquery_update.js":1,"sites\/all\/modules\/guardian_weather\/js\/weather.js":1,"sites\/all\/modules\/lightbox2\/js\/lightbox.js":1,"sites\/all\/modules\/views\/js\/base.js":1,"misc\/progress.js":1,"sites\/all\/modules\/views\/js\/ajax_view.js":1,"sites\/all\/modules\/field_group\/field_group.js":1,"sites\/all\/modules\/spotim-comments\/js\/spot_im.js":1,"sites\/all\/themes\/publishing\/js\/sites.js":1,"1":1},"css":{"modules\/system\/system.base.css":1,"modules\/system\/system.menus.css":1,"modules\/system\/system.messages.css":1,"modules\/system\/system.theme.css":1,"modules\/aggregator\/aggregator.css":1,"sites\/all\/modules\/date\/date_api\/date.css":1,"sites\/all\/modules\/date\/date_popup\/themes\/datepicker.1.7.css":1,"modules\/field\/theme\/field.css":1,"sites\/all\/modules\/guardian_weather\/css\/weather.css":1,"modules\/node\/node.css":1,"modules\/poll\/poll.css":1,"modules\/user\/user.css":1,"sites\/all\/modules\/youtube\/css\/youtube.css":1,"sites\/all\/modules\/views\/css\/views.css":1,"sites\/all\/modules\/ckeditor\/css\/ckeditor.css":1,"sites\/all\/modules\/ctools\/css\/ctools.css":1,"sites\/all\/modules\/lightbox2\/css\/lightbox.css":1,"sites\/all\/modules\/sharebar\/css\/sharebar.css":1,"sites\/all\/themes\/publishing\/css\/default.css":1,"sites\/all\/themes\/publishing\/css\/layout.css":1,"sites\/all\/themes\/publishing\/css\/style.css":1,"sites\/all\/themes\/publishing\/css\/normalize.css":1,"sites\/all\/themes\/publishing\/css\/responsive.css":1}},"lightbox2":{"rtl":0,"file_path":"\/(\\w\\w\/)public:\/","default_image":"\/sites\/all\/modules\/lightbox2\/images\/brokenimage.jpg","border_size":10,"font_color":"000","box_color":"fff","top_position":"","overlay_opacity":"0.8","overlay_color":"000","disable_close_click":true,"resize_sequence":0,"resize_speed":400,"fade_in_speed":400,"slide_down_speed":600,"use_alt_layout":false,"disable_resize":false,"disable_zoom":false,"force_show_nav":false,"show_caption":true,"loop_items":false,"node_link_text":"View Image Details","node_link_target":false,"image_count":"Image !current of !total","video_count":"Video !current of !total","page_count":"Page !current of !total","lite_press_x_close":"press \u003Ca href=\u0022#\u0022 onclick=\u0022hideLightbox(); return FALSE;\u0022\u003E\u003Ckbd\u003Ex\u003C\/kbd\u003E\u003C\/a\u003E to close","download_link_text":"","enable_login":false,"enable_contact":false,"keys_close":"c x 27","keys_previous":"p 37","keys_next":"n 39","keys_zoom":"z","keys_play_pause":"32","display_image_size":"original","image_node_sizes":"()","trigger_lightbox_classes":"","trigger_lightbox_group_classes":"","trigger_slideshow_classes":"","trigger_lightframe_classes":"","trigger_lightframe_group_classes":"","custom_class_handler":0,"custom_trigger_classes":"","disable_for_gallery_lists":true,"disable_for_acidfree_gallery_lists":true,"enable_acidfree_videos":true,"slideshow_interval":5000,"slideshow_automatic_start":true,"slideshow_automatic_exit":true,"show_play_pause":true,"pause_on_next_click":false,"pause_on_previous_click":true,"loop_slides":false,"iframe_width":600,"iframe_height":400,"iframe_border":1,"enable_video":false},"views":{"ajax_path":"\/views\/ajax","ajaxViews":{"views_dom_id:55a7ade268a10d847488d21189d1cea9":{"view_name":"publication_most_read","view_display_id":"block","view_args":"","view_path":"node\/147601","view_base_path":null,"view_dom_id":"55a7ade268a10d847488d21189d1cea9","pager_element":0}}},"urlIsAjaxTrusted":{"\/views\/ajax":true},"field_group":{"div":"full"}});
//--><!]]>
</script>
<script type="text/javascript">

  var _gaq = _gaq || [];
  _gaq.push(['_setAccount', 'UA-21130176-21']);
  _gaq.push(['_trackPageview']);

  (function() {
    var ga = document.createElement('script'); ga.type = 'text/javascript'; ga.async = true;
    ga.src = ('https:' == document.location.protocol ? 'https://ssl' : 'http://www') + '.google-analytics.com/ga.js';
    var s = document.getElementsByTagName('script')[0]; s.parentNode.insertBefore(ga, s);
  })();

</script>
<script type="text/javascript">

  var _gaq = _gaq || [];
  _gaq.push(['_setAccount', 'UA-21130176-19']);
  _gaq.push(['_setDomainName', 'guardian.co.tt']);
  _gaq.push(['_setAllowLinker', true]);
  _gaq.push(['_trackPageview']);

  (function() {
    var ga = document.createElement('script'); ga.type = 'text/javascript'; ga.async = true;
    ga.src = ('https:' == document.location.protocol ? 'https://ssl' : 'http://www') + '.google-analytics.com/ga.js';
    var s = document.getElementsByTagName('script')[0]; s.parentNode.insertBefore(ga, s);
  })();

</script>
<link rel="shortcut icon" type="image/ico" href="http://www.guardian.co.tt/images/gfavicon.ico" />
<meta http-equiv="X-UA-Compatible" content="IE=edge" />
<meta name="application-name" content="The Trinidad Guardian Newspaper" />
<meta name="msapplication-starturl" content="http://www.guardian.co.tt" />
<meta name="msapplication-navbutton-color" content="#EB1D25" />
<meta name="viewport" content="width=device-width, initial-scale=1.0, maximum-scale=5.0, user-scalable=yes">
<meta name="msapplication-tooltip" content="Start Trinidad Guardian Newspaper" />

</head>
<body class="html not-front not-logged-in two-sidebars page-node page-node- page-node-147601 node-type-articlestory   news">
<div id="search">
<a href="#" class="close">close</a>
<h4> Search </h4>
<div id="search-block-form">
<script>
  (function() {
    var cx = 'partner-pub-4814196096164925:9533398938';
    var gcse = document.createElement('script');
    gcse.type = 'text/javascript';
    gcse.async = true;
    gcse.src = (document.location.protocol == 'https:' ? 'https:' : 'http:') +
        '//www.google.com/cse/cse.js?cx=' + cx;
    var s = document.getElementsByTagName('script')[0];
    s.parentNode.insertBefore(gcse, s);
  })();
</script>
<gcse:search></gcse:search>
</div>
</div>
<div id="page" class="page">

<div id="header">
<div id="logo">
<a href="/" title="Home" rel="home" id="logo">
<img src="http://www.guardian.co.tt/sites/all/themes/publishing/logo.png" alt="Home" />
</a>
</div>
<div id="updated">Last update: 30-Aug-2018 6:53 am<br />
Thursday, August 30, 2018<br />
</div>
<div id="social">
<div id="social-media">
<a href="http://guardian.co.tt/sitemap" id="rss" target="_blank"></a>
<a href="https://twitter.com/guardiantt" id="twitter" target="_blank"></a>
<a href="https://www.facebook.com/ttguardian" id="facebook" target="_blank"></a>
<a href="https://plus.google.com/u/0/b/114657292481933475304/" id="googleplus" target="_blank"></a>
<a href="/cdn-cgi/l/email-protection#5930372d3c2b373c2d773c3d302d362b193e2c382b3d303837773a36772d2d" id="mail" target="_blank"></a>
<p id="site-title">Trinidad & Tobago Guardian Online</p>
</div>
</div>
<div id="header-region">
<div class="region region-header">
<div id="block-block-106" class="block block-block mobile-menu block-odd clearfix">
<div class="block-inner">
<div class="content">
<a href="#" id="menu-button">menu</a> </div>
</div>
</div> <div id="block-menu-menu-short-menu" class="block block-menu no-title block-even clearfix">
<div class="block-inner">
<h2 class="block-title">Short Menu</h2>
<div class="content">
<ul class="menu"><li class="first leaf"><a href="/news">News</a></li>
<li class="leaf"><a href="/sports">Sport</a></li>
<li class="leaf"><a href="/business">Business</a></li>
<li class="leaf mobile-link"><a href="http://www.guardian.co.tt/business-guardian">Business Guardian</a></li>
<li class="leaf"><a href="/lifestyle">Lifestyle</a></li>
<li class="leaf"><a href="/columnists">Columnists</a></li>
<li class="leaf mobile-link"><a href="http://www.guardian.co.tt/Letters">Letters</a></li>
<li class="leaf mobile-link"><a href="http://www.guardian.co.tt/entertainment">Entertainment</a></li>
<li class="leaf"><a href="/editorial">Editorial</a></li>
<li class="leaf mobile-link"><a href="/death-notices">Death Notices</a></li>
<li class="leaf mobile-link"><a href="http://classifieds.guardian.co.tt/RealEstate/Default.aspx" target="_blank">Classifieds</a></li>
<li class="leaf mobile-link"><a href="http://subscriptions.guardian.co.tt/edg/" target="_blank">Digital Guardian</a></li>
<li class="leaf mobile-link"><a href="http://www.guardian.co.tt/archive" target="_blank">Archives</a></li>
<li class="leaf mobile-link"><a href="http://classifieds.guardian.co.tt/RealEstate/Default.aspx" target="_blank">Real Estate</a></li>
<li class="leaf mobile-link"><a href="http://www.guardian.co.tt/digital/subscriptions" target="_blank">Subscriptions</a></li>
<li class="leaf mobile-link"><a href="http://www.guardian.co.tt/your-stories">Your Stories</a></li>
<li class="last leaf mobile-link"><a href="http://iamaguardiantt.tumblr.com/" target="_blank">I am Guardian</a></li>
</ul> </div>
</div>
</div>  </div>
</div>
<ol id="sec-menu">

<li><a id="search-button" href="#">Search</a></li>
</ol>
</div> 
<div id="hidden-menu">
<div class="region region-hidden-menu">
<div id="block-system-user-menu" class="block block-system no-title block-menu block-odd clearfix">
<div class="block-inner">
<h2 class="block-title">User menu</h2>
<div class="content">
<ul class="menu"><li class="first leaf"><a href="/business-guardian">Business Guardian</a></li>
<li class="leaf"><a href="/entertainment">Entertainment</a></li>
<li class="leaf"><a href="/Letters">Letters</a></li>
<li class="leaf"><a href="/death-notices">Death Notices</a></li>
<li class="leaf"><a href="http://www.guardian.co.tt/archive">Archives</a></li>
<li class="leaf"><a href="http://classifieds.guardian.co.tt/RealEstate/Default.aspx">Real Estate</a></li>
<li class="leaf"><a href="http://classifieds.guardian.co.tt/" target="_blank">Classifieds</a></li>
<li class="leaf no-mobile"><a href="http://www.guardian.co.tt/digital/subscriptions" target="_blank">Subscriptions</a></li>
<li class="leaf no-mobile"><a href="http://iamaguardiantt.tumblr.com/" target="_blank">I am Guardian</a></li>
<li class="last leaf"><a href="http://www.guardian.co.tt/sea">SEA Math</a></li>
</ul> </div>
</div>
</div>  </div>
</div>
<div id="banner">
<div class="region region-banner">
<div id="block-block-11" class="block block-block top-ad desktopad ads728 cell-lg-7 block-even clearfix">
<div class="block-inner">
<div class="content">
<center><iframe src="http://www.guardian.co.tt/adcode/leaderboard.html" frameborder="0" width="728" height="90" style="padding:0; margin:0;" scrolling="no"></iframe></center> </div>
</div>
</div> <div id="block-block-63" class="block block-block digital-ad desktopad  cell-lg-5 block-odd clearfix">
<div class="block-inner">
<div class="content">
<center><iframe src="http://www.guardian.co.tt/adcode/headersmall.html" frameborder="0" width="450" height="90" style="padding:0; margin:0;" scrolling="no"></iframe></center> </div>
</div>
</div> <div id="block-block-107" class="block block-block ads600 mobileads block-even clearfix">
<div class="block-inner">
<div class="content">
<script data-cfasync="false" src="/cdn-cgi/scripts/5c5dd728/cloudflare-static/email-decode.min.js"></script><script type='text/javascript'>
  var googletag = googletag || {};
  googletag.cmd = googletag.cmd || [];
  (function() {
    var gads = document.createElement('script');
    gads.async = true;
    gads.type = 'text/javascript';
    var useSSL = 'https:' == document.location.protocol;
    gads.src = (useSSL ? 'https:' : 'http:') +
      '//www.googletagservices.com/tag/js/gpt.js';
    var node = document.getElementsByTagName('script')[0];
    node.parentNode.insertBefore(gads, node);
  })();
</script>
<script type='text/javascript'>
  googletag.cmd.push(function() {
    googletag.defineSlot('/103800131/mobile600', [600, 100], 'div-gpt-ad-1466003545412-0').addService(googletag.pubads());
    googletag.pubads().enableSingleRequest();
    googletag.pubads().collapseEmptyDivs();
    googletag.enableServices();
  });
</script>

<div id='div-gpt-ad-1466003545412-0' style='height:100px; width:600px; margin:0 auto;'>
<script type='text/javascript'>
googletag.cmd.push(function() { googletag.display('div-gpt-ad-1466003545412-0'); });
</script>
</div> </div>
</div>
</div> <div id="block-block-108" class="block block-block ads320 mobileads block-odd clearfix">
<div class="block-inner">
<div class="content">
<script type='text/javascript'>
  var googletag = googletag || {};
  googletag.cmd = googletag.cmd || [];
  (function() {
    var gads = document.createElement('script');
    gads.async = true;
    gads.type = 'text/javascript';
    var useSSL = 'https:' == document.location.protocol;
    gads.src = (useSSL ? 'https:' : 'http:') +
      '//www.googletagservices.com/tag/js/gpt.js';
    var node = document.getElementsByTagName('script')[0];
    node.parentNode.insertBefore(gads, node);
  })();
</script>
<script type='text/javascript'>
  googletag.cmd.push(function() {
    googletag.defineSlot('/103800131/mobile320', [320, 90], 'div-gpt-ad-1467390568976-0').addService(googletag.pubads());
    googletag.pubads().enableSingleRequest();
    googletag.pubads().collapseEmptyDivs();
    googletag.enableServices();
  });
</script>

<div id='div-gpt-ad-1467390568976-0' style='height:90px; width:320px; margin:0 auto;'>
<script type='text/javascript'>
googletag.cmd.push(function() { googletag.display('div-gpt-ad-1467390568976-0'); });
</script>
</div> </div>
</div>
</div>  </div>
</div>

<div id="main" class="clearfix">
<div id="content">
<div id="content-inner" class="inner column center">
<div id="content-header">
<h2 class="element-invisible">You are here</h2><div class="breadcrumb"><a href="/">Home</a></div>
<div class="strapandslug"></div>
<h1 class="title">Eight arrested as four guns seized in west Trinidad</h1>
<div class="tabs"></div>
</div> 

<div id="content-area">
<div class="region region-content">
<ul id="sharebarp" style="background:#FFFFFF;border-color:#ffffff;margin-top:10px;width: 350px; float: left; margin-right:-20pxpx;"><li>
<g:plusone></g:plusone>

<script type="text/javascript">
  (function() {
    var po = document.createElement('script'); po.type = 'text/javascript'; po.async = true;
    po.src = 'https://apis.google.com/js/plusone.js';
    var s = document.getElementsByTagName('script')[0]; s.parentNode.insertBefore(po, s);
  })();
</script></li><li><a href="https://twitter.com/share" class="twitter-share-button" data-count="horizontal" data-via="guardiantt">Tweet</a><script type="text/javascript" src="https://platform.twitter.com/widgets.js"></script></li><li><iframe src="https://www.facebook.com/plugins/like.php?href=http://www.guardian.co.tt/news/2018-08-30/eight-arrested-four-guns-seized-west-trinidad&layout=button_count&show_faces=false&width=85&action=like&colorscheme=light&height=21" scrolling="no" frameborder="0" style="border:none; overflow:hidden; width:85px; height:21px;" allowTransparency="true"></iframe></li></ul><div id="block-system-main" class="block block-system block-even clearfix">
<div class="block-inner">
<div class="content">
<div id="node-147601" class="node node-articlestory node-promoted node-odd">
<div class="node-inner">
<div class="desktopads ads600">
<center>
<script async src="//pagead2.googlesyndication.com/pagead/js/adsbygoogle.js"></script>

<ins class="adsbygoogle" style="display:inline-block;width:580px;height:90px" data-ad-client="ca-pub-4814196096164925" data-ad-slot="4646641906"></ins>
<script>
        (adsbygoogle = window.adsbygoogle || []).push({});
        </script>
</center>
</div>
<div class="content">
<div id=content-read>
<div class="field field-name-field-date field-type-datetime field-label-inline clearfix"><div class="field-label">Published:&nbsp;</div><div class="field-items"><div class="field-item even"><span class="date-display-single" property="dc:date" datatype="xsd:dateTime" content="2018-08-30T00:00:00-04:00">Thursday, August 30, 2018</span></div></div></div><div class="group-image field-group-div"><div class="field field-name-field-image field-type-image field-label-hidden"><div class="field-items"><div class="field-item even"><img typeof="foaf:Image" src="http://www.guardian.co.tt/sites/default/files/field/image/guns%20big.jpg" width="400" height="247" alt="" /></div></div></div><div class="field field-name-field-caption field-type-text-long field-label-hidden"><div class="field-items"><div class="field-item even">Three guns which were recovered by police during an exercise in Diego Martin.</div></div></div></div><div class="field field-name-body field-type-text-with-summary field-label-hidden"><div class="field-items"><div class="field-item even" property="content:encoded"><p>Western Division police have arrested eight men in relation to the seizure of four illegal firearms, this week.</p>
<p>Police arrested five of the suspects on Monday after they stopped their Nissan B15 along the Western Main Road in Westmoorings.</p>
<p>Police found a loaded Glock 17 pistol with 11 rounds of 9 mm ammunition. The gun was also outfitted with a selector which allows the user to fire automatic bursts from the semi-automatic pistol.</p>
<p>The suspects, ages 18 to 21, all from Factory Road in Diego Martin were arrested.</p>
<p>Almost 24 hours later, officers of the Western Division Task Force (WDTF) led by Sgt Ulric Arneaud were on patrol in Richplain, Diego Martin, when they observed three armed men in a bushy area. The men attempted to run away but were arrested.</p>
<p>The officers recovered an FX-9 machine gun, a 12-gauge pump action shotgun, a Glock pistol and 14 rounds of assorted ammunition.</p>
<p>The pistol was also outfitted with a selector.</p>
<p>The eight suspects remained detained up to late yesterday and are expected to be taken to court today.</p>
</div></div></div><div class="field field-name-field-topic field-type-taxonomy-term-reference field-label-hidden"><div class="field-items"><div class="field-item even"><a href="/category/topic/news" typeof="skos:Concept" property="rdfs:label skos:prefLabel" datatype="">News</a></div></div></div> </div>
<div id='node_nav'><strong><div class="prev_link">Previous Article <br /><a href="/news/2018-08-30/ansa-mcal-host-concert-fireworks">ANSA McAL to host concert, fireworks</a></div><div class="next_link">Next Article<br /><a href="/news/2018-08-30/drastic-reduction-road-deaths%E2%80%94police">Drastic reduction in road deaths—police</a></div></strong></div></div>
<div class="desktopads ads600">
<center>
<script async src="//pagead2.googlesyndication.com/pagead/js/adsbygoogle.js"></script>

<ins class="adsbygoogle" style="display:inline-block;width:580px;height:90px" data-ad-client="ca-pub-4814196096164925" data-ad-slot="4646641906"></ins>
<script>
        (adsbygoogle = window.adsbygoogle || []).push({});
        </script>
</center>
</div>
<div class="links"></div>
</div> 
</div> 
</div>
</div>
</div> <div id="block-block-23" class="block block-block disclaimer block-odd clearfix">
<div class="block-inner">
<h2 class="block-title">Disclaimer</h2>
<div class="content">
<div style="font-size:11px; margin-left:auto; margin-right:auto; width:90%">
<p>User comments posted on this website are the sole views and opinions of the comment writer and are not representative of Guardian Media Limited or its staff.</p>
<p>Guardian Media Limited accepts no liability and will not be held accountable for user comments.</p>
<p>Guardian Media Limited reserves the right to remove, to edit or to censor any comments.</p>
<p>Any content which is considered unsuitable, unlawful or offensive, includes personal details, advertises or promotes products, services or websites or repeats previous comments will be removed.</p>
<p>Before posting, please refer to the <a href="../../../house-rules">Community Standards</a>, <a href="../../../terms-of-services">Terms and conditions</a> and <a href="../../../privacy">Privacy Policy</a></p>
<p><em>User profiles registered through fake social media accounts may be deleted without notice.</em></p>
</div>
</div>
</div>
</div> <div id="block-block-117" class="block block-block block-even clearfix">
<div class="block-inner">
<div class="content">
<div data-spotim-module="recirculation" data-spot-id="sp_XC61vFgU"></div>
<script async src="https://recirculation.spot.im/spot/sp_XC61vFgU"></script>
<script async src="https://launcher.spot.im/spot/sp_XC61vFgU" data-spotim-module="spotim-launcher" data-post-id="Eight arrested as four guns seized in west Trinidad"></script> </div>
</div>
</div>  </div>
</div>
</div>
</div> 


<div id="sidebar-first" class="column sidebar first">
<div id="sidebar-first-inner" class="inner">
<div class="region region-sidebar-first">
<div id="block-views-publication_most_read-block" class="block block-views internal-popular no-mobile block-odd clearfix">
<div class="block-inner">
<h2 class="block-title">In case you missed it.</h2>
<div class="content">
<div class="view view-publication-most-read view-id-publication_most_read view-display-id-block view-dom-id-55a7ade268a10d847488d21189d1cea9">
<div class="view-content">
<table class="views-view-grid cols-1">
<tbody>
<tr class="row-1 row-first">
<td class="col-1 col-first">
<div class="views-field views-field-title"> <span class="field-content"><a href="/news/2018-08-28/airport-heist-could-have-been-avoided%E2%80%94epa">Airport heist could have been avoided—EPA</a></span> </div>
<div class="views-field views-field-field-image"> <div class="field-content"><img typeof="foaf:Image" src="http://www.guardian.co.tt/sites/default/files/styles/thumbnail/public/field/image/Estate%20Police%20Association.jpg?itok=SpbQoDpX" width="100" height="62" alt="" /></div> </div>
<div class="views-field views-field-body"> <div class="field-content"><p>A $5 million robbery at the cargo dock at the Piarco International Airport, last December, could have been avoided.</p></div> </div> </td>
</tr>
<tr class="row-2">
<td class="col-1 col-first">
<div class="views-field views-field-title"> <span class="field-content"><a href="/business-guardian/2018-08-29/venezuelan-gas-deal-risk-versus-rewardwill">The Venezuelan gas deal: Risk versus rewardwill</a></span> </div>
<div class="views-field views-field-field-image"> <div class="field-content"><img typeof="foaf:Image" src="http://www.guardian.co.tt/sites/default/files/styles/thumbnail/public/field/image/refinery%20a.jpg?itok=Bxm0vsBE" width="100" height="94" alt="" /></div> </div>
<div class="views-field views-field-body"> <div class="field-content"><p>The “historic” gas deal signed between T&amp;T and Venezuela on August 25, 2018 is a structural solution to T&amp;T’s gas supply woes experienced by the petrochemical sector over the last few...</div> </div> </td>
</tr>
<tr class="row-3">
<td class="col-1 col-first">
<div class="views-field views-field-title"> <span class="field-content"><a href="/sports/2018-08-29/gopaulsingh-pierre-get-masters-silver-medals">Gopaulsingh, Pierre get Masters silver medals</a></span> </div>
<div class="views-field views-field-field-image"> <div class="field-content"><img typeof="foaf:Image" src="http://www.guardian.co.tt/sites/default/files/styles/thumbnail/public/field/image/medals_0.jpg?itok=DGO6lbfv" width="75" height="100" alt="" /></div> </div>
<div class="views-field views-field-body"> <div class="field-content"><p>T&amp;T’s Anton Gopaulsingh and Rochelle Pierre were the lone top three medal winners for this country at the just concluded Pan American Masters Swimming Championship in Orlando, Florida.</p></div> </div> </td>
</tr>
<tr class="row-4">
<td class="col-1 col-first">
<div class="views-field views-field-title"> <span class="field-content"><a href="/sports/2018-08-29/babwah-barnes-cop-carebaco-gold">Babwah, Barnes cop Carebaco gold</a></span> </div>
<div class="views-field views-field-field-image"> <div class="field-content"><img typeof="foaf:Image" src="http://www.guardian.co.tt/sites/default/files/styles/thumbnail/public/field/image/minton%20raket.jpg?itok=wS5uRq3D" width="100" height="69" alt="" /></div> </div>
<div class="views-field views-field-body"> <div class="field-content"><p>The local pair of Andrew Babwah and T’Shelle Barnes won T&amp;T’s second gold medal at the Under-11 to Under-17 CAREBACO (Caribbean Regional Badminton Confederation) Championship when the final...</div> </div> </td>
</tr>
<tr class="row-5">
<td class="col-1 col-first">
<div class="views-field views-field-title"> <span class="field-content"><a href="/news/2018-08-28/gas-price-hike-coming">Gas price hike coming</a></span> </div>
<div class="views-field views-field-field-image"> <div class="field-content"><img typeof="foaf:Image" src="http://www.guardian.co.tt/sites/default/files/styles/thumbnail/public/field/image/Petrotrin%20workers%201.jpg?itok=QtuqhcJ8" width="100" height="87" alt="" /></div> </div>
<div class="views-field views-field-body"> <div class="field-content"><p>Predicting an exponential increase in fuel prices at the pumps if the Government succeeded in shutting down the Pointe-a-Pierre refinery, Oilfield Workers’ Trade Union president general Ancel...</div> </div> </td>
</tr>
<tr class="row-6">
<td class="col-1 col-first">
<div class="views-field views-field-title"> <span class="field-content"><a href="/sports/2018-08-29/maracas-open-water-classic-set-sept-16">Maracas Open Water Classic set for Sept 16</a></span> </div>
<div class="views-field views-field-field-image"> <div class="field-content"><img typeof="foaf:Image" src="http://www.guardian.co.tt/sites/default/files/styles/thumbnail/public/field/image/Graham%20Chatoor_0.jpg?itok=4PXIcIFV" width="100" height="78" alt="" /></div> </div>
<div class="views-field views-field-body"> <div class="field-content"><p>The 2018 edition of the Subway Maracas Open Water Classic will come off on Sunday, September 16 at the Maracas Bay, Maracas from 8 am.</p></div> </div> </td>
</tr>
<tr class="row-7">
<td class="col-1 col-first">
<div class="views-field views-field-title"> <span class="field-content"><a href="/news/2018-08-29/we%E2%80%99ll-try-soften-blow">We’ll try to soften blow</a></span> </div>
<div class="views-field views-field-field-image"> <div class="field-content"><img typeof="foaf:Image" src="http://www.guardian.co.tt/sites/default/files/styles/thumbnail/public/field/image/Wilfred%20Espin%20roget_0.jpg?itok=aDUHbHY7" width="100" height="80" alt="" /></div> </div>
<div class="views-field views-field-body"> <div class="field-content"><p>Exit packages for the more than 3,000 employees at state-owned Petrotrin are being worked out but the company is in no position to say how much this exercise will cost, what exactly will be...</div> </div> </td>
</tr>
<tr class="row-8">
<td class="col-1 col-first">
<div class="views-field views-field-title"> <span class="field-content"><a href="/news/2018-08-30/eight-arrested-four-guns-seized-west-trinidad" class="active">Eight arrested as four guns seized in west Trinidad</a></span> </div>
<div class="views-field views-field-field-image"> <div class="field-content"><img typeof="foaf:Image" src="http://www.guardian.co.tt/sites/default/files/styles/thumbnail/public/field/image/guns%20big.jpg?itok=tU2lCt0p" width="100" height="62" alt="" /></div> </div>
<div class="views-field views-field-body"> <div class="field-content"><p>Western Division police have arrested eight men in relation to the seizure of four illegal firearms, this week.</p></div> </div> </td>
</tr>
<tr class="row-9">
<td class="col-1 col-first">
<div class="views-field views-field-title"> <span class="field-content"><a href="/news/2018-08-28/importing-fuel-won%E2%80%99t-cause-hike">Importing fuel won’t cause hike</a></span> </div>
<div class="views-field views-field-field-image"> <div class="field-content"><img typeof="foaf:Image" src="http://www.guardian.co.tt/sites/default/files/styles/thumbnail/public/field/image/petrotrintower_0.jpg?itok=bkQA1Mb_" width="100" height="70" alt="" /></div> </div>
<div class="views-field views-field-body"> <div class="field-content"><p>The Government will now determine whether there are price hikes in fuel supplies to consumers when Petrotrin shuts down its refinery and begins importing fuel.</p></div> </div> </td>
</tr>
<tr class="row-10 row-last">
<td class="col-1 col-first">
<div class="views-field views-field-title"> <span class="field-content"><a href="/news/2018-08-28/kesar-not-true-owtu-played-role-purported-sale-petrotrin-refinery">Kesar: Not true that OWTU played role in purported sale of Petrotrin refinery</a></span> </div>
<div class="views-field views-field-field-image"> <div class="field-content"><img typeof="foaf:Image" src="http://www.guardian.co.tt/sites/default/files/styles/thumbnail/public/field/image/Petrotrin%20tank.jpg?itok=AJRR-BB9" width="100" height="70" alt="" /></div> </div>
<div class="views-field views-field-body"> <div class="field-content"><p>Trinmar’s Branch President Ernesto Kesar is debunking any notion that the Oilfield Workers Trade Union (OWTU) had anything to do with the purported sale of Petrotrin’s refinery.</p></div> </div> </td>
</tr>
</tbody>
</table>
</div>
</div> </div>
</div>
</div>  </div>
</div>
</div>

<div id="sidebar-second" class="column sidebar second">
<div id="sidebar-second-inner" class="inner">
<div class="region region-sidebar-second">
<div id="block-block-97" class="block block-block advertisment ads block-even clearfix">
<div class="block-inner">
<div class="content">
<script async='async' src='https://www.googletagservices.com/tag/js/gpt.js'></script>
<script>
  var googletag = googletag || {};
  googletag.cmd = googletag.cmd || [];
</script>
<script>
  googletag.cmd.push(function() {
    googletag.defineSlot('/103800131/Guardian300x250', [300, 250], 'div-gpt-ad-1506623274501-0').addService(googletag.pubads());
    googletag.pubads().enableSingleRequest();
    googletag.pubads().collapseEmptyDivs();
    googletag.enableServices();
  });
</script>

<div id='div-gpt-ad-1506623274501-0' style='height:250px; width:300px;'>
<script>
googletag.cmd.push(function() { googletag.display('div-gpt-ad-1506623274501-0'); });
</script>
</div> </div>
</div>
</div> <div id="block-block-98" class="block block-block advertisment ads block-odd clearfix">
<div class="block-inner">
<div class="content">
<center><iframe src="http://www.guardian.co.tt/adcode/sidebar2.html" width="300" height="250" style="padding:0; margin:0; border:none; overflow:hidden" scrolling="no"></iframe></center> </div>
</div>
</div> <div id="block-block-9" class="block block-block advertisment google block-even clearfix">
<div class="block-inner">
<div class="content">
<center>
<script async src="//pagead2.googlesyndication.com/pagead/js/adsbygoogle.js"></script>

<ins class="adsbygoogle" style="display:inline-block;width:300px;height:250px" data-ad-client="ca-pub-4814196096164925" data-ad-slot="3725503905"></ins>
<script>
(adsbygoogle = window.adsbygoogle || []).push({});
</script>
</center> </div>
</div>
</div>  </div>
</div>
</div>

</div> 

<div id="footer_bottom">
<div class="region region-footer-bottom">
<div id="block-block-62" class="block block-block gml-logo left block-odd clearfix">
<div class="block-inner">
<div class="content">
<p><a href="http://corp.guardian.co.tt" target="_blank"><img alt="" src="data:image/png;base64,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" style="margin:5px 10px" /></a></p>
		</div>

  </div>
</div> <!-- /block-inner /block --><div id="block-block-6" class="block block-block disclaimer right block-even clearfix">
  <div class="block-inner">

                		
		<div class="content" >
		  <p>GUARDIAN MEDIA is not responsible for the content of external sites. Copyright © 2014 GUARDIAN MEDIA LIMITED</p>
		</div>

  </div>
</div> <!-- /block-inner /block --><div id="block-menu-menu-footer-links" class="block block-menu footer_menu right block-odd clearfix">
  <div class="block-inner">

                <h2 class="block-title">Footer links</h2>
          		
		<div class="content" >
		  <ul class="menu"><li class="first leaf"><a href="http://www.guardian.co.tt/annual-reports" target="_blank">Annual Reports</a></li>
<li class="leaf"><a href="/contact">Contact Us</a></li>
<li class="leaf"><a href="http://www.guardian.co.tt/archive">Archives</a></li>
<li class="leaf"><a href="http://www.guardian.co.tt/advertisewithus">E-Advertise with us</a></li>
<li class="leaf"><a href="/terms-of-services">Terms of Service</a></li>
<li class="leaf"><a href="/privacy">Privacy</a></li>
<li class="leaf"><a href="http://www.guardian.co.tt/rss.xml">RSS</a></li>
<li class="last leaf"><a href="/sitemap">Sitemap</a></li>
</ul>		</div>

  </div>
</div> <!-- /block-inner /block -->  </div>
    </div> <!-- /footer -->
  
</div> <!-- /page -->
  </body>
</html>
